blob: 795c9b9c946d791f5a719803f94c96fe4b652171 [file] [log] [blame]
Brad Bishop30f78552017-01-28 12:51:42 -05001SUMMARY = "Generate inventory map for phosphor-ipmi-fru from an MRW."
2PR = "r1"
3
4inherit native
5inherit phosphor-ipmi-fru
Matt Spinler3f6fcbe2017-12-14 13:31:55 -06006inherit mrw-xml
Brad Bishop30f78552017-01-28 12:51:42 -05007
8require phosphor-ipmi-fru.inc
9
10DEPENDS += "mrw-native mrw-perl-tools-native"
11
12# TODO: remove this dependency after the MRW script
13# has been updated to not require the hostfw metadata.
14DEPENDS += "virtual/phosphor-ipmi-fru-hostfw-config"
15
16PROVIDES += "virtual/phosphor-ipmi-fru-inventory"
17
18S = "${WORKDIR}/git"
19do_install() {
20
21 DEST=${D}${config_datadir}
22 install -d ${DEST}
23
24 ${bindir}/perl-native/perl \
25 ${bindir}/gen_ipmi_fru.pl \
Matt Spinler3f6fcbe2017-12-14 13:31:55 -060026 -i ${mrw_datadir}/${MRW_XML} \
Brad Bishop30f78552017-01-28 12:51:42 -050027 -m ${hostfw_datadir}/config.yaml \
28 -o ${DEST}/config.yaml
29}