Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Phosphor State Management" |
| 2 | DESCRIPTION = "Phosphor State Manager provides a set of system state \ |
| 3 | management daemons. It is suitable for use on a wide variety of OpenBMC \ |
| 4 | platforms." |
| 5 | HOMEPAGE = "https://github.com/openbmc/phosphor-state-manager" |
| 6 | PR = "r1" |
| 7 | LICENSE = "Apache-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 9 | |
| 10 | STATE_MGR_PACKAGES = " \ |
| 11 | ${PN}-host \ |
| 12 | ${PN}-chassis \ |
Josh King | a946288 | 2017-01-19 14:04:03 -0600 | [diff] [blame] | 13 | ${PN}-bmc \ |
Michael Tritz | 7199d26 | 2017-04-18 17:01:12 -0500 | [diff] [blame] | 14 | ${PN}-discover \ |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 15 | " |
| 16 | PACKAGES =+ "${STATE_MGR_PACKAGES}" |
Brad Bishop | c3f1057 | 2017-03-01 16:08:45 -0500 | [diff] [blame] | 17 | PACKAGES_remove = "${PN}" |
| 18 | RDEPENDS_${PN}-dev = "${STATE_MGR_PACKAGES}" |
| 19 | RDEPENDS_${PN}-staticdev = "${STATE_MGR_PACKAGES}" |
| 20 | |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 21 | DBUS_PACKAGES = "${STATE_MGR_PACKAGES}" |
| 22 | |
| 23 | # Set SYSTEMD_PACKAGES to empty because we do not want ${PN} and DBUS_PACKAGES |
| 24 | # handles the rest. |
| 25 | SYSTEMD_PACKAGES = "" |
| 26 | |
| 27 | inherit autotools pkgconfig |
| 28 | inherit obmc-phosphor-dbus-service |
| 29 | |
| 30 | DEPENDS += "autoconf-archive-native" |
| 31 | DEPENDS += "sdbusplus" |
| 32 | DEPENDS += "phosphor-logging" |
Patrick Williams | d0486d8 | 2017-01-30 11:06:16 -0600 | [diff] [blame] | 33 | DEPENDS += "phosphor-dbus-interfaces" |
Adriana Kobylak | a6fc67f | 2017-01-30 20:30:00 -0600 | [diff] [blame] | 34 | RDEPENDS_${PN} += "sdbusplus" |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 35 | |
Patrick Williams | d0486d8 | 2017-01-30 11:06:16 -0600 | [diff] [blame] | 36 | RDEPENDS_${PN}-host += "libsystemd phosphor-dbus-interfaces" |
| 37 | RDEPENDS_${PN}-chassis += "libsystemd phosphor-dbus-interfaces" |
| 38 | RDEPENDS_${PN}-bmc += "libsystemd phosphor-dbus-interfaces" |
Michael Tritz | 7199d26 | 2017-04-18 17:01:12 -0500 | [diff] [blame] | 39 | RDEPENDS_${PN}-discover += "libsystemd phosphor-dbus-interfaces" |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 40 | |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 41 | FILES_${PN}-host = "${sbindir}/phosphor-host-state-manager" |
| 42 | DBUS_SERVICE_${PN}-host += "xyz.openbmc_project.State.Host.service" |
| 43 | |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 44 | FILES_${PN}-chassis = "${sbindir}/phosphor-chassis-state-manager" |
| 45 | DBUS_SERVICE_${PN}-chassis += "xyz.openbmc_project.State.Chassis.service" |
| 46 | |
Josh King | a946288 | 2017-01-19 14:04:03 -0600 | [diff] [blame] | 47 | FILES_${PN}-bmc = "${sbindir}/phosphor-bmc-state-manager" |
| 48 | DBUS_SERVICE_${PN}-bmc += "xyz.openbmc_project.State.BMC.service" |
| 49 | |
Michael Tritz | 7199d26 | 2017-04-18 17:01:12 -0500 | [diff] [blame] | 50 | FILES_${PN}-discover = "${sbindir}/phosphor-discover-system-state" |
| 51 | |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 52 | SRC_URI += "git://github.com/openbmc/phosphor-state-manager" |
Patrick Williams | 93023a8 | 2017-04-20 10:50:05 -0500 | [diff] [blame] | 53 | SRCREV = "cc3fb5d9a720a9a5b2102683da716004cd938e39" |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 54 | |
| 55 | S = "${WORKDIR}/git" |