blob: 1ae5669b00f3223c0cd89f7b14fdbd253f9c5eaf [file] [log] [blame]
Jayanth Othayoth9963d172017-05-08 09:25:05 -05001SUMMARY = "Phosphor Debug Collector"
2DESCRIPTION = "Phosphor Debug Collector provides mechanisms \
3to collect various FFDC files and system parameters. \
4This will be helpful for troubleshooting the problems in OpenBMC \
5based systems."
6
7PR = "r1"
8
Jayanth Othayoth9d21d6c2017-05-31 06:25:55 -05009DEBUG_COLLECTOR_PKGS = " \
10 ${PN}-manager \
11 ${PN}-monitor \
Jayanth Othayothd2592492017-07-29 22:28:44 -050012 ${PN}-dreport \
Jayanth Othayoth9d21d6c2017-05-31 06:25:55 -050013"
14PACKAGES =+ "${DEBUG_COLLECTOR_PKGS}"
15PACKAGES_remove = "${PN}"
16RDEPENDS_${PN}-dev = "${DEBUG_COLLECTOR_PKGS}"
17RDEPENDS_${PN}-staticdev = "${DEBUG_COLLECTOR_PKGS}"
18
19DBUS_PACKAGES = "${PN}-manager"
20
21SYSTEMD_PACKAGES = "${PN}-monitor"
22
Jayanth Othayoth9963d172017-05-08 09:25:05 -050023inherit autotools \
24 pkgconfig \
Jayanth Othayothaae91e32017-06-05 03:10:00 -050025 obmc-phosphor-dbus-service \
Jayanth Othayoth5f6d8852017-07-05 10:31:16 -050026 pythonnative \
27 phosphor-debug-collector
Jayanth Othayoth9963d172017-05-08 09:25:05 -050028
29require phosphor-debug-collector.inc
30
31DEPENDS += " \
32 phosphor-dbus-interfaces \
33 phosphor-dbus-interfaces-native \
34 phosphor-logging \
35 sdbusplus \
36 sdbusplus-native \
37 autoconf-archive-native \
Jayanth Othayoth9d21d6c2017-05-31 06:25:55 -050038"
Jayanth Othayoth9963d172017-05-08 09:25:05 -050039
Jayanth Othayoth9d21d6c2017-05-31 06:25:55 -050040RDEPENDS_${PN}-manager += " \
Jayanth Othayoth9963d172017-05-08 09:25:05 -050041 sdbusplus \
42 phosphor-dbus-interfaces \
43 phosphor-logging \
Jayanth Othayothd2592492017-07-29 22:28:44 -050044 ${PN}-dreport \
Jayanth Othayoth9d21d6c2017-05-31 06:25:55 -050045"
46RDEPENDS_${PN}-monitor += " \
47 sdbusplus \
48 phosphor-dbus-interfaces \
49 phosphor-logging \
50"
Jayanth Othayothd2592492017-07-29 22:28:44 -050051RDEPENDS_${PN}-dreport += " \
52 systemd \
53 ${VIRTUAL-RUNTIME_base-utils} \
54 bash \
55"
Jayanth Othayoth9963d172017-05-08 09:25:05 -050056
Jayanth Othayoth5f6d8852017-07-05 10:31:16 -050057MGR_SVC ?= "xyz.openbmc_project.Dump.Manager.service"
58
59SYSTEMD_SUBSTITUTIONS += "BMC_DUMP_PATH:${bmc_dump_path}:${MGR_SVC}"
60
Jayanth Othayoth9d21d6c2017-05-31 06:25:55 -050061FILES_${PN}-manager += "${sbindir}/phosphor-dump-manager"
62FILES_${PN}-monitor += "${sbindir}/phosphor-dump-monitor"
Jayanth Othayothd2592492017-07-29 22:28:44 -050063FILES_${PN}-dreport += "${bindir}/dreport"
Jayanth Othayoth9d21d6c2017-05-31 06:25:55 -050064
Jayanth Othayoth5f6d8852017-07-05 10:31:16 -050065DBUS_SERVICE_${PN}-manager += "${MGR_SVC}"
Jayanth Othayoth9d21d6c2017-05-31 06:25:55 -050066SYSTEMD_SERVICE_${PN}-monitor += "obmc-dump-monitor.service"
Jayanth Othayoth9963d172017-05-08 09:25:05 -050067
Jayanth Othayothf1b85172017-07-05 10:54:35 -050068EXTRA_OECONF = "BMC_DUMP_PATH=${bmc_dump_path}"
Jayanth Othayoth5f6d8852017-07-05 10:31:16 -050069
Jayanth Othayoth9963d172017-05-08 09:25:05 -050070S = "${WORKDIR}/git"
Jayanth Othayothd2592492017-07-29 22:28:44 -050071
72do_install_append() {
73 install -d ${D}${bindir}
74 install -m 0755 ${S}/tools/dreport \
75 ${D}${bindir}/dreport
76}