blob: 12e1955ae37e7a3f5025e62bf195eaebf7f0e7ab [file] [log] [blame]
Brad Bishop86605732015-11-18 10:56:38 -05001FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
Brad Bishop85e90ff2018-06-06 16:16:23 -04002SRC_URI += "file://0001-json-Use-int-long.__str__-to-convert-subclasses.patch"
Brad Bishop86605732015-11-18 10:56:38 -05003
Brad Bishop86605732015-11-18 10:56:38 -05004require wsgiref-${PYTHON_MAJMIN}-manifest.inc
5
Brad Bishopaada1562018-06-07 19:10:54 -04006PROVIDES_prepend = "${PN}-spwd "
7PACKAGES_prepend = "${PN}-spwd "
Brad Bishop86605732015-11-18 10:56:38 -05008
9SUMMARY_${PN}-spwd = "Shadow database support"
10RDEPENDS_${PN}-spwd = "${PN}-core"
11FILES_${PN}-spwd= " \
12 ${libdir}/python${PYTHON_MAJMIN}/lib-dynload/spwd.so \
13 ${libdir}/python${PYTHON_MAJMIN}/lib-dynload/grp.so \
14 "
Andrew Geissler20e22db2018-08-29 06:06:42 -070015# Remove all python .py files from python recipe. Only the .pyc
16# files are required. Only do this if the openbmc-phosphor-tiny
17# distro feature is enabled
18do_install_append_openbmc-phosphor-tiny() {
19 find ${D}${libdir}/python${PYTHON_MAJMIN} -name \*.py -exec rm {} \;
20 # This is a system configuration file generated during build time.
21 # It's used in the yocto packaging process so it is required to
22 # remain in the image.
23 cp ${WORKDIR}/recipe-sysroot-native/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata.py ${D}${libdir}/python${PYTHON_MAJMIN}/
24}