Kuiying Wang | 0d73765 | 2018-11-08 16:52:49 +0800 | [diff] [blame] | 1 | SUMMARY = "OpenBMC Buttons" |
| 2 | DESCRIPTION = "OpenBMC All buttons" |
| 3 | PR = "r1" |
| 4 | PV = "1.0+git${SRCPV}" |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 7 | |
| 8 | S = "${WORKDIR}/git" |
| 9 | SRC_URI += "git://github.com/openbmc/phosphor-buttons.git" |
Andrew Geissler | 443f1b0 | 2018-12-10 19:00:27 +0000 | [diff] [blame] | 10 | SRCREV = "391a21a1bb002a62ce336bfacdd8fdf888b7909a" |
Kuiying Wang | 0d73765 | 2018-11-08 16:52:49 +0800 | [diff] [blame] | 11 | |
| 12 | inherit cmake pkgconfig systemd |
| 13 | |
Matt Spinler | f69dd65 | 2018-11-26 15:37:30 -0600 | [diff] [blame] | 14 | BUTTON_PACKAGES="${PN}-signals ${PN}-handler" |
| 15 | |
| 16 | ALLOW_EMPTY_${PN} = "1" |
| 17 | PACKAGE_BEFORE_PN += "${BUTTON_PACKAGES}" |
| 18 | PACKAGECONFIG ??= "signals handler" |
| 19 | SYSTEMD_PACKAGES = "${BUTTON_PACKAGES}" |
| 20 | |
| 21 | PACKAGECONFIG[signals] = ",,gpioplus nlohmann-json," |
| 22 | PACKAGECONFIG[handler] = ",,,phosphor-state-manager-chassis phosphor-state-manager-host" |
| 23 | |
| 24 | FILES_${PN}-signals = "${sbindir}/buttons" |
| 25 | SYSTEMD_SERVICE_${PN}-signals = "xyz.openbmc_project.Chassis.Buttons.service" |
| 26 | |
| 27 | FILES_${PN}-handler = "${sbindir}/button-handler" |
| 28 | SYSTEMD_SERVICE_${PN}-handler = "phosphor-button-handler.service" |
Kuiying Wang | 0d73765 | 2018-11-08 16:52:49 +0800 | [diff] [blame] | 29 | |
| 30 | DEPENDS += " \ |
| 31 | systemd \ |
| 32 | sdbusplus \ |
| 33 | phosphor-dbus-interfaces \ |
| 34 | phosphor-logging \ |
Kuiying Wang | 0d73765 | 2018-11-08 16:52:49 +0800 | [diff] [blame] | 35 | " |