blob: c71064558c14930c440ba97d0c4c22d6323de002 [file] [log] [blame]
Lei YU4d8175e2019-10-21 10:39:07 +08001SUMMARY = "Phosphor Power services and utilities"
2DESCRIPTION = "Configure and monitor power supplies, power sequencers, and \
3voltage regulators, and analyzes power devices for faults"
4PR = "r1"
5PV = "1.0+git${SRCPV}"
6
7inherit meson
8inherit pkgconfig
9inherit systemd
10inherit pythonnative
11
12require ${PN}.inc
13
14S = "${WORKDIR}/git"
15
16# TODO: in future when openpower-dbus-interfaces is removed from
17# phosphor-power, remove the dependency here.
18DEPENDS += " \
19 phosphor-logging \
20 openpower-dbus-interfaces \
21 sdbus++-native \
22 sdeventplus \
23 nlohmann-json \
Jim Wright7a0e57f2019-11-06 15:43:43 -060024 cli11 \
Matthew Barth16867e42019-12-20 15:37:07 -060025 i2c-tools \
Lei YU4d8175e2019-10-21 10:39:07 +080026 "
27
Brandon Wyman4d2907b2020-01-23 16:30:02 -060028PACKAGE_BEFORE_PN = "phosphor-psu-monitor"
29FILES_phosphor-psu-monitor = "${bindir}/phosphor-psu-monitor \
30 ${systemd_system_unitdir}/phosphor-psu-monitor.service"
31
Lei YU4d8175e2019-10-21 10:39:07 +080032SEQ_MONITOR_SVC = "pseq-monitor.service"
33SEQ_PGOOD_SVC = "pseq-monitor-pgood.service"
34PSU_MONITOR_TMPL = "power-supply-monitor@.service"
35SYSTEMD_SERVICE_${PN} += "${SEQ_MONITOR_SVC} ${SEQ_PGOOD_SVC} ${PSU_MONITOR_TMPL}"
Matthew Barth280eeb92019-12-20 15:21:55 -060036
37# Package all phosphor-regulators config files
38FILES_${PN} += "${datadir}/phosphor-regulators"
Matthew Barthfa58fcd2019-12-20 15:42:35 -060039
40# ${PN}-regulators service/systemd setup
41REGS_SVC = "phosphor-regulators.service"
42SYSTEMD_SERVICE_${PN} += "${REGS_SVC}"