Brad Bishop | 02f8e88 | 2016-04-15 09:23:44 -0400 | [diff] [blame] | 1 | SUMMARY = "Phosphor python library" |
| 2 | DESCRIPTION = "Phosphor python library." |
Brad Bishop | 0239063 | 2016-06-09 01:26:47 -0400 | [diff] [blame] | 3 | HOMEPAGE = "http://github.com/openbmc/pyphosphor" |
Brad Bishop | 02f8e88 | 2016-04-15 09:23:44 -0400 | [diff] [blame] | 4 | PR = "r1" |
Patrick Venture | 82e4191 | 2018-10-17 07:24:38 -0700 | [diff] [blame] | 5 | PV = "1.0+git${SRCPV}" |
Brad Bishop | 02f8e88 | 2016-04-15 09:23:44 -0400 | [diff] [blame] | 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 8 | |
| 9 | inherit allarch |
| 10 | inherit setuptools |
Brad Bishop | 1b4e447 | 2016-08-29 21:47:04 -0400 | [diff] [blame] | 11 | inherit python-dir |
| 12 | |
| 13 | PACKAGE_BEFORE_PN = " \ |
| 14 | ${PN}-ns \ |
| 15 | ${PN}-utils-ns \ |
| 16 | ${PN}-dbus-ns \ |
Brad Bishop | 56fa348 | 2016-08-29 21:51:58 -0400 | [diff] [blame] | 17 | ${PN}-wsgi-ns \ |
| 18 | ${PN}-wsgi-apps-ns \ |
Brad Bishop | 1b4e447 | 2016-08-29 21:47:04 -0400 | [diff] [blame] | 19 | ${PN}-utils \ |
| 20 | ${PN}-dbus \ |
| 21 | " |
| 22 | |
| 23 | RDEPENDS_${PN}-utils-ns += "${PN}-ns" |
| 24 | RDEPENDS_${PN}-dbus-ns += "${PN}-ns" |
| 25 | RDEPENDS_${PN}-utils += "${PN}-utils-ns" |
Brad Bishop | 56fa348 | 2016-08-29 21:51:58 -0400 | [diff] [blame] | 26 | RDEPENDS_${PN}-wsgi-apps-ns += "${PN}-wsgi-ns" |
| 27 | RDEPENDS_${PN}-wsgi-ns += "${PN}-ns" |
Brad Bishop | 1b4e447 | 2016-08-29 21:47:04 -0400 | [diff] [blame] | 28 | RDEPENDS_${PN}-dbus += " \ |
| 29 | ${PN}-dbus-ns \ |
| 30 | python-dbus \ |
| 31 | python-xml \ |
| 32 | python-json \ |
| 33 | python-pickle \ |
| 34 | " |
| 35 | RDEPENDS_${PN} += " \ |
| 36 | ${PN}-ns \ |
| 37 | ${PN}-dbus \ |
| 38 | python-subprocess \ |
| 39 | python-dbus \ |
| 40 | " |
| 41 | |
| 42 | FILES_${PN}-ns = "${PYTHON_SITEPACKAGES_DIR}/obmc/__init__.py*" |
| 43 | FILES_${PN}-utils-ns = "${PYTHON_SITEPACKAGES_DIR}/obmc/utils/__init__.py*" |
| 44 | FILES_${PN}-dbus-ns = "${PYTHON_SITEPACKAGES_DIR}/obmc/dbuslib/__init__.py*" |
Brad Bishop | 56fa348 | 2016-08-29 21:51:58 -0400 | [diff] [blame] | 45 | FILES_${PN}-wsgi-ns = "${PYTHON_SITEPACKAGES_DIR}/obmc/wsgi/__init__.py*" |
| 46 | FILES_${PN}-wsgi-apps-ns = "${PYTHON_SITEPACKAGES_DIR}/obmc/wsgi/apps/__init__.py*" |
Brad Bishop | 1b4e447 | 2016-08-29 21:47:04 -0400 | [diff] [blame] | 47 | |
| 48 | FILES_${PN}-utils = "${PYTHON_SITEPACKAGES_DIR}/obmc/utils" |
| 49 | FILES_${PN}-dbus = "${PYTHON_SITEPACKAGES_DIR}/obmc/dbuslib" |
Brad Bishop | 02f8e88 | 2016-04-15 09:23:44 -0400 | [diff] [blame] | 50 | |
| 51 | SRC_URI += "git://github.com/openbmc/pyphosphor" |
| 52 | |
Andrew Geissler | 082080e | 2018-09-10 19:50:16 +0000 | [diff] [blame] | 53 | SRCREV = "d2aadf1220b03580ab5f93fd15e068040cdb895b" |
Brad Bishop | 02f8e88 | 2016-04-15 09:23:44 -0400 | [diff] [blame] | 54 | |
| 55 | S = "${WORKDIR}/git" |