blob: 26e805e1b221ea5175b5b06649fe2fa2dc2614a1 [file] [log] [blame]
Brad Bishopce086742015-10-27 17:12:45 -04001SUMMARY = "Phosphor DBUS Object Manager"
2DESCRIPTION = "Phosphor DBUS object manager."
3HOMEPAGE = "http://github.com/openbmc/phosphor-objmgr"
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
7
Brad Bishopce086742015-10-27 17:12:45 -04008inherit obmc-phosphor-dbus-service
9inherit obmc-phosphor-systemd
10inherit setuptools
11
Brad Bishop48b19612016-08-07 23:18:32 -040012DEPENDS += "systemd"
Rick Altherrc38aae02016-08-01 14:20:50 -070013
Brad Bishopa5983c92016-08-16 09:40:10 -040014DBUS_SERVICE_${PN} += "org.openbmc.ObjectMapper.service"
Brad Bishop231230b2016-08-08 20:04:29 -040015SYSTEMD_SERVICE_${PN} = "mapper-wait@.service"
Brad Bishopce086742015-10-27 17:12:45 -040016RDEPENDS_${PN} += " \
17 python-xml \
18 python-dbus \
19 python-pygobject \
20 "
Chris Austen350def12015-12-02 22:32:06 -060021SRC_URI += "git://github.com/openbmc/phosphor-objmgr"
Brad Bishopce086742015-10-27 17:12:45 -040022
Patrick Williamsb7c98dd2016-08-30 12:10:02 -050023SRCREV = "a6797f83a23778b6f99d1e0f471b908fd01cb7b5"
Brad Bishopce086742015-10-27 17:12:45 -040024
25S = "${WORKDIR}/git"
Brad Bishop9a701b42016-07-26 15:52:01 -040026
27do_compile_append() {
28 oe_runmake -C libmapper
29}
30
31do_install_append() {
32 oe_runmake -C libmapper install DESTDIR=${D}
33}
34
35python populate_packages_prepend () {
36 mapperlibdir = d.getVar("libdir", True)
37 do_split_packages(d, mapperlibdir, '^lib(.*)\.so\.*', 'lib%s', 'Phosphor mapper %s library', extra_depends='', allow_links=True)
38}
39PACKAGES_DYNAMIC += "^libmapper.*"
40FILES_${PN}_remove = "${libdir}/lib*.so.* ${libdir}/*"