Vishwanatha Subbanna | 55c545a | 2017-06-12 13:09:10 +0530 | [diff] [blame] | 1 | SUMMARY = "Phosphor Watchdog application" |
| 2 | DESCRIPTION = "Application that implements software watchdog" |
| 3 | HOMEPAGE = "http://github.com/openbmc/phosphor-watchdog" |
| 4 | PR = "r1" |
| 5 | |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 8 | inherit autotools pkgconfig |
| 9 | inherit obmc-phosphor-dbus-service |
| 10 | |
| 11 | RPROVIDES_${PN} += "virtual/obmc-watchdog" |
| 12 | PROVIDES += "virtual/obmc-watchdog" |
| 13 | |
| 14 | DEPENDS += "autoconf-archive-native" |
| 15 | DEPENDS += "sdbusplus sdbusplus-native" |
| 16 | DEPENDS += "phosphor-dbus-interfaces" |
| 17 | DEPENDS += "phosphor-logging" |
| 18 | RDEPENDS_${PN} += "libsystemd" |
| 19 | RDEPENDS_${PN} += "phosphor-logging" |
| 20 | |
| 21 | SRC_URI += "git://github.com/openbmc/phosphor-watchdog" |
Patrick Williams | 0144e66 | 2017-09-12 11:40:13 -0500 | [diff] [blame] | 22 | SRCREV = "96816341eb591865d011531b17d0be887f2e0e90" |
Vishwanatha Subbanna | 55c545a | 2017-06-12 13:09:10 +0530 | [diff] [blame] | 23 | S = "${WORKDIR}/git" |
| 24 | |
| 25 | # Copies config file having arguments for host watchdog |
| 26 | SYSTEMD_ENVIRONMENT_FILE_${PN} +="obmc/watchdog/poweron" |
| 27 | |
| 28 | # Install the override to set up a Conflicts relation |
| 29 | SYSTEMD_OVERRIDE_${PN} += "poweron.conf:phosphor-watchdog@poweron.service.d/poweron.conf" |
| 30 | |
| 31 | # For now, watching PowerOn is the only usecase |
| 32 | OBMC_HOST_WATCHDOG_INSTANCES = "poweron" |
| 33 | |
| 34 | # This is really a DBUS service but the service name is |
| 35 | # an argument, so making it this way. |
| 36 | WATCHDOG_TMPL = "phosphor-watchdog@.service" |
Vishwanatha Subbanna | d8b3f61 | 2017-07-03 19:21:18 +0530 | [diff] [blame] | 37 | ENABLE_WATCHDOG_TMPL = "obmc-enable-host-watchdog@.service" |
Vishwanatha Subbanna | 55c545a | 2017-06-12 13:09:10 +0530 | [diff] [blame] | 38 | SYSTEMD_SERVICE_${PN} += "${WATCHDOG_TMPL}" |
| 39 | |
Vishwanatha Subbanna | d8b3f61 | 2017-07-03 19:21:18 +0530 | [diff] [blame] | 40 | # To Enable Host Watchdog early during poweron |
| 41 | SYSTEMD_SERVICE_${PN} += "${ENABLE_WATCHDOG_TMPL}" |
| 42 | |
Vishwanatha Subbanna | 55c545a | 2017-06-12 13:09:10 +0530 | [diff] [blame] | 43 | WATCHDOG_TGTFMT = "phosphor-watchdog@{0}.service" |
Vishwanatha Subbanna | d8b3f61 | 2017-07-03 19:21:18 +0530 | [diff] [blame] | 44 | ENABLE_WATCHDOG_TGTFMT = "obmc-enable-host-watchdog@{0}.service" |
| 45 | |
Vishwanatha Subbanna | 55c545a | 2017-06-12 13:09:10 +0530 | [diff] [blame] | 46 | WATCHDOG_FMT = "../${WATCHDOG_TMPL}:obmc-host-start@{1}.target.wants/${WATCHDOG_TGTFMT}" |
Vishwanatha Subbanna | d8b3f61 | 2017-07-03 19:21:18 +0530 | [diff] [blame] | 47 | ENABLE_WATCHDOG_FMT = "../${ENABLE_WATCHDOG_TMPL}:obmc-host-start@{0}.target.wants/${ENABLE_WATCHDOG_TGTFMT}" |
| 48 | |
Vishwanatha Subbanna | 55c545a | 2017-06-12 13:09:10 +0530 | [diff] [blame] | 49 | SYSTEMD_LINK_${PN} += "${@compose_list(d, 'WATCHDOG_FMT', 'OBMC_HOST_WATCHDOG_INSTANCES', 'OBMC_HOST_INSTANCES')}" |
Vishwanatha Subbanna | d8b3f61 | 2017-07-03 19:21:18 +0530 | [diff] [blame] | 50 | SYSTEMD_LINK_${PN} += "${@compose_list(d, 'ENABLE_WATCHDOG_FMT', 'OBMC_HOST_INSTANCES')}" |