Artem Senichev | 8135af9 | 2018-11-02 16:46:13 +0300 | [diff] [blame] | 1 | SUMMARY = "Phosphor Host logger" |
| 2 | DESCRIPTION = "Save log messages from host's console to the persistent storage." |
| 3 | HOMEPAGE = "https://github.com/openbmc/phosphor-hostlogger" |
| 4 | PR = "r1" |
| 5 | PV = "1.0+git${SRCPV}" |
| 6 | |
| 7 | inherit autotools |
| 8 | inherit pkgconfig |
| 9 | inherit pythonnative |
| 10 | inherit systemd |
| 11 | |
| 12 | # License info |
| 13 | LICENSE = "Apache-2.0" |
| 14 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 15 | |
| 16 | # Dependencies |
| 17 | DEPENDS += "sdbusplus \ |
| 18 | sdbusplus-native \ |
| 19 | phosphor-dbus-interfaces" |
| 20 | RDEPENDS_${PN} += "obmc-console" |
| 21 | RRECOMMENDS_${PN} += "phosphor-debug-collector" |
| 22 | |
| 23 | # systemd service setup |
| 24 | SYSTEMD_PACKAGES = "${PN}" |
| 25 | SYSTEMD_SERVICE_${PN} = "hostlogger.service" |
| 26 | SYSTEMD_DEFAULT_TARGET ?= "multi-user.target" |
| 27 | |
| 28 | # Host TTY setup |
| 29 | OBMC_CONSOLE_HOST_TTY ?= "ttyVUART0" |
| 30 | |
| 31 | # Extra parameters for 'configure' script |
| 32 | EXTRA_OECONF = "HOST_TTY=${OBMC_CONSOLE_HOST_TTY} \ |
| 33 | SYSTEMD_TARGET=${SYSTEMD_DEFAULT_TARGET}" |
| 34 | |
| 35 | # Source code repository |
| 36 | S = "${WORKDIR}/git" |
| 37 | SRC_URI = "git://github.com/openbmc/phosphor-hostlogger" |
| 38 | SRCREV = "4d5a5dcd6f974166c8d0f2657e0079a7f3fc5e01" |