Marri Devender Rao | 139b373 | 2018-10-09 07:53:30 -0500 | [diff] [blame] | 1 | SUMMARY = "Phosphor certificate manager configuration for an nslcd authority service" |
| 2 | |
| 3 | PR = "r1" |
| 4 | |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/LICENSE;md5=19407077e42b1ba3d653da313f1f5b4e" |
| 7 | |
Brad Bishop | 1a4e65e | 2019-03-21 19:08:15 -0400 | [diff] [blame] | 8 | RDEPENDS_${PN} = "phosphor-certificate-manager" |
Marri Devender Rao | 139b373 | 2018-10-09 07:53:30 -0500 | [diff] [blame] | 9 | |
| 10 | inherit allarch |
Marri Devender Rao | 139b373 | 2018-10-09 07:53:30 -0500 | [diff] [blame] | 11 | |
Brad Bishop | 1a4e65e | 2019-03-21 19:08:15 -0400 | [diff] [blame] | 12 | SRC_URI = "file://env" |
| 13 | |
| 14 | do_install() { |
| 15 | install -D ${WORKDIR}/env ${D}/${sysconfdir}/default/obmc/cert/authority |
| 16 | } |
| 17 | |
| 18 | pkg_postinst_${PN}() { |
| 19 | LINK="$D$systemd_system_unitdir/multi-user.target.wants/phosphor-certificate-manager@authority.service" |
| 20 | TARGET="../phosphor-certificate-manager@.service" |
| 21 | mkdir -p $D$systemd_system_unitdir/multi-user.target.wants |
| 22 | ln -s $TARGET $LINK |
| 23 | } |
| 24 | |
| 25 | pkg_prerm_${PN}() { |
| 26 | LINK="$D$systemd_system_unitdir/multi-user.target.wants/phosphor-certificate-manager@authority.service" |
| 27 | rm $LINK |
| 28 | } |