Leonel Gonzalez | 3562b95 | 2017-04-11 08:27:58 -0500 | [diff] [blame] | 1 | |
| 2 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
| 3 | |
| 4 | SRC_URI += "file://rngd.service" |
| 5 | |
| 6 | inherit systemd |
| 7 | |
| 8 | SYSTEMD_SERVICE_${PN} = "rngd.service" |
| 9 | |
| 10 | do_install_append() { |
| 11 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then |
| 12 | install -d ${D}${systemd_unitdir}/system |
| 13 | install -m 644 ${WORKDIR}/rngd.service ${D}${systemd_unitdir}/system |
| 14 | sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/rngd.service |
| 15 | fi |
| 16 | } |
| 17 | |