Patrick Williams | 6ed002f | 2016-06-22 16:30:42 -0500 | [diff] [blame] | 1 | SUMMARY = "Python GObject bindings" |
| 2 | SECTION = "devel/python" |
| 3 | LICENSE = "LGPLv2.1" |
| 4 | |
| 5 | RECIPE_NO_UPDATE_REASON = "Newer versions of python-pygobject depend on gobject-introspection which doesn't cross-compile" |
| 6 | |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7" |
| 8 | DEPENDS = "python python-pygobject-native libffi glib-2.0" |
| 9 | DEPENDS_class-native = "python-native libffi-native glib-2.0-native" |
| 10 | RDEPENDS_class-native = "" |
| 11 | |
| 12 | MAJ_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}" |
| 13 | |
Brad Bishop | 2b226d1 | 2018-02-23 14:35:39 -0500 | [diff] [blame] | 14 | SRC_URI = "${GNOME_MIRROR}/pygobject/${MAJ_VER}/pygobject-${PV}.tar.xz \ |
Patrick Williams | 6ed002f | 2016-06-22 16:30:42 -0500 | [diff] [blame] | 15 | file://obsolete_automake_macros.patch \ |
| 16 | " |
| 17 | |
| 18 | # libtool-native doesn't have fixinstall.patch applied which means |
| 19 | # that libs get relinked at installation time. This triggers a |
| 20 | # relinking along the lines of: |
| 21 | # gcc -L/tmp/foo/media/build1/poky/build/tmp/sysroots/x86_64-linux/usr/lib -lpyglib-2.0-python -o .libs/_glib.so |
| 22 | # where /tmp/foo is DESTDIR and pyglib-2.0-python may be installed/reinstalled |
| 23 | # at the same time as the gcc command runs. |
| 24 | # If this happens between the handoff between gcc and ld, you can see: |
| 25 | # /bin/ld: cannot find -lpyglib-2.0-python |
| 26 | # Adding a dependency rule like install-pyglibLTLIBRARIES: install-libLTLIBRARIES |
| 27 | # would be ideal but automake can't cope with that without manually |
| 28 | # defining the whole function. Give up and disable parallel make in native builds. |
| 29 | PARALLEL_MAKEINST_class-native = "" |
| 30 | |
Brad Bishop | 2b226d1 | 2018-02-23 14:35:39 -0500 | [diff] [blame] | 31 | SRC_URI[md5sum] = "ae48b60c690c4aa894e69e0c97802745" |
| 32 | SRC_URI[sha256sum] = "bb9d25a3442ca7511385a7c01b057492095c263784ef31231ffe589d83a96a5a" |
Patrick Williams | 6ed002f | 2016-06-22 16:30:42 -0500 | [diff] [blame] | 33 | S = "${WORKDIR}/pygobject-${PV}" |
| 34 | |
| 35 | EXTRA_OECONF += "--disable-introspection" |
| 36 | |
| 37 | inherit autotools distutils-base pkgconfig |
| 38 | |
| 39 | # necessary to let the call for python-config succeed |
| 40 | export BUILD_SYS |
| 41 | export HOST_SYS |
| 42 | export STAGING_INCDIR |
| 43 | export STAGING_LIBDIR |
| 44 | |
| 45 | PACKAGES += "${PN}-lib" |
| 46 | |
| 47 | RDEPENDS_${PN} += "python-textutils" |
| 48 | |
| 49 | FILES_${PN} = "${libdir}/python*" |
| 50 | FILES_${PN}-lib = "${libdir}/lib*.so.*" |
| 51 | FILES_${PN}-dev += "${bindir} ${datadir}" |
| 52 | |
| 53 | BBCLASSEXTEND = "native" |