blob: 7157c7e1231799b5a64b2c171c437662d96b8096 [file] [log] [blame]
Patrick Ventureaf570492018-09-22 18:56:00 -07001SUMMARY = "Phosphor OEM IPMI Ethernet Stats Implementation"
2DESCRIPTION = "This package handles receiving OEM IPMI commands to provide ethernet device statistics."
3HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-ethstats"
4PR = "r1"
5PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9inherit autotools pkgconfig
10inherit obmc-phosphor-ipmiprovider-symlink
11
12DEPENDS += "autoconf-archive-native"
13DEPENDS += "phosphor-ipmi-host"
14
15S = "${WORKDIR}/git"
16SRC_URI = "git://github.com/openbmc/phosphor-ipmi-ethstats"
Andrew Geissler789d1462019-03-08 17:21:59 +000017SRCREV = "d087d81ae3cad0df1d641c87144909e46fcb20fb"
Patrick Ventureaf570492018-09-22 18:56:00 -070018
19FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
20FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
21FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
22FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
23
24HOSTIPMI_PROVIDER_LIBRARY += "libethstatscmd.so"