Joel Stanley | 79d1653 | 2016-03-21 12:24:40 +1030 | [diff] [blame] | 1 | DESCRIPTION = "Linux kernel for OpenBMC" |
| 2 | SECTION = "kernel" |
| 3 | LICENSE = "GPLv2" |
| 4 | |
| 5 | KBRANCH ?= "dev-4.4" |
| 6 | KCONFIG_MODE="--alldefconfig" |
| 7 | |
| 8 | SRC_URI = "git://github.com/openbmc/linux;protocol=git;branch=${KBRANCH}" |
| 9 | |
| 10 | LINUX_VERSION ?= "4.4" |
| 11 | LINUX_VERSION_EXTENSION ?= "-${SRCREV}" |
| 12 | |
Joel Stanley | c75b3c4 | 2016-05-21 07:25:22 +0930 | [diff] [blame] | 13 | SRCREV="openbmc-20160521-1" |
Joel Stanley | 79d1653 | 2016-03-21 12:24:40 +1030 | [diff] [blame] | 14 | |
| 15 | PV = "${LINUX_VERSION}+git${SRCPV}" |
| 16 | |
| 17 | COMPATIBLE_MACHINE_${MACHINE} = "openbmc" |
| 18 | |
| 19 | inherit kernel |
| 20 | require recipes-kernel/linux/linux-yocto.inc |
Brad Bishop | 4f6a577 | 2016-05-06 20:35:43 -0400 | [diff] [blame] | 21 | |
| 22 | do_patch_append() { |
| 23 | for DTB in "${KERNEL_DEVICETREE}"; do |
| 24 | DT=`basename ${DTB} .dtb` |
| 25 | if [ -r "${WORKDIR}/${DT}.dts" ]; then |
| 26 | cp ${WORKDIR}/${DT}.dts \ |
| 27 | ${STAGING_KERNEL_DIR}/arch/${ARCH}/boot/dts |
| 28 | fi |
| 29 | done |
| 30 | } |