blob: 09d40e53592a838552ac05baf70d112efa5b3248 [file] [log] [blame]
Joel Stanley79d16532016-03-21 12:24:40 +10301DESCRIPTION = "Linux kernel for OpenBMC"
2SECTION = "kernel"
3LICENSE = "GPLv2"
4
5KBRANCH ?= "dev-4.4"
6KCONFIG_MODE="--alldefconfig"
7
8SRC_URI = "git://github.com/openbmc/linux;protocol=git;branch=${KBRANCH}"
9
10LINUX_VERSION ?= "4.4"
11LINUX_VERSION_EXTENSION ?= "-${SRCREV}"
12
Joel Stanleyc75b3c42016-05-21 07:25:22 +093013SRCREV="openbmc-20160521-1"
Joel Stanley79d16532016-03-21 12:24:40 +103014
15PV = "${LINUX_VERSION}+git${SRCPV}"
16
17COMPATIBLE_MACHINE_${MACHINE} = "openbmc"
18
19inherit kernel
20require recipes-kernel/linux/linux-yocto.inc