blob: 37d67f8a653262ed1b1dcba5809df9f471a2ee57 [file] [log] [blame]
Jason M. Billsb2911ec2018-10-26 14:07:48 -07001SUMMARY = "Journal IPMI SEL Logger"
2DESCRIPTION = "Utility to write IPMI SEL records to the journal"
3
4# SEL Logger has the ability to monitor and automatically log SEL records for
5# various types of events, but this is disabled by default. The following
6# flags can be set in a .bbappend to enable specific types of event
7# monitoring:
8#
9# SEL_LOGGER_MONITOR_THRESHOLD_EVENTS:
10# Monitors and logs SEL records for threshold sensor events
11
12inherit cmake systemd
Brad Bishop29d26b32020-10-27 09:22:51 -040013S = "${WORKDIR}/git"
Jason M. Billsb2911ec2018-10-26 14:07:48 -070014
15LICENSE = "Apache-2.0"
16LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
17
18DEPENDS += "systemd sdbusplus boost phosphor-ipmi-host"
19
20SRC_URI = "git://github.com/openbmc/phosphor-sel-logger.git;protocol=git"
Andrew Geisslerec3fdd42020-10-05 20:21:39 +000021SRCREV = "df7bc1c6951fb7dd2776008aa0b7dc6bea44bed4"
Jason M. Billsb2911ec2018-10-26 14:07:48 -070022
23PV = "0.1+git${SRCPV}"
24
25SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Logging.IPMI.service"