Patrick Williams | 7aba815 | 2020-03-31 14:22:32 -0500 | [diff] [blame] | 1 | inherit obmc-phosphor-python-autotools |
| 2 | include sdbus++.inc |
| 3 | |
Patrick Williams | 07ce0de | 2020-04-01 10:15:29 -0500 | [diff] [blame] | 4 | SRC_URI += "file://0001-Revert-sdbus-switch-to-python3.patch" |
| 5 | |
Patrick Williams | 7aba815 | 2020-03-31 14:22:32 -0500 | [diff] [blame] | 6 | # Provide these aliases temporarily until everyone can move over to the |
| 7 | # new package name. |
| 8 | PROVIDES_class-native += "sdbusplus-native sdbus++-native" |
| 9 | PROVIDES_class-nativesdk += "sdbusplus-nativesdk sdbus++-nativesdk" |
Patrick Williams | 737cd1a | 2020-04-01 10:04:17 -0500 | [diff] [blame] | 10 | |
| 11 | # If anyone wanted the sdbus++ executable, make them use the python3 version. |
| 12 | # This avoids issues where both packages attempt to install the executable |
| 13 | # into /usr/bin. |
| 14 | DEPENDS += "python3-sdbus++-native" |
| 15 | do_install_append() { |
| 16 | rm ${D}${bindir}/sdbus++ |
| 17 | rmdir ${D}${bindir} || true |
| 18 | } |