blob: 2426d43ee72c1014fcac7cf3a785614efdc481d1 [file] [log] [blame]
Artem Senichev8135af92018-11-02 16:46:13 +03001SUMMARY = "Phosphor Host logger"
2DESCRIPTION = "Save log messages from host's console to the persistent storage."
3HOMEPAGE = "https://github.com/openbmc/phosphor-hostlogger"
4PR = "r1"
5PV = "1.0+git${SRCPV}"
6
7inherit autotools
8inherit pkgconfig
9inherit pythonnative
10inherit systemd
11
12# License info
13LICENSE = "Apache-2.0"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
15
16# Dependencies
Alexander Filippov74dc8702019-01-10 12:38:09 +030017DEPENDS += "\
18 autoconf-archive-native \
19 sdbusplus \
Patrick Williams2bebd122020-03-31 16:43:15 -050020 ${PYTHON_PN}-sdbus++-native \
Alexander Filippov74dc8702019-01-10 12:38:09 +030021 phosphor-dbus-interfaces \
22 "
Artem Senichev8135af92018-11-02 16:46:13 +030023RDEPENDS_${PN} += "obmc-console"
24RRECOMMENDS_${PN} += "phosphor-debug-collector"
25
26# systemd service setup
27SYSTEMD_PACKAGES = "${PN}"
28SYSTEMD_SERVICE_${PN} = "hostlogger.service"
Artem Senichev8135af92018-11-02 16:46:13 +030029
30# Host TTY setup
31OBMC_CONSOLE_HOST_TTY ?= "ttyVUART0"
32
33# Extra parameters for 'configure' script
34EXTRA_OECONF = "HOST_TTY=${OBMC_CONSOLE_HOST_TTY} \
Patrick Ventured607cfb2019-04-04 12:15:22 -070035 SYSTEMD_TARGET=multi-user.target"
Artem Senichev8135af92018-11-02 16:46:13 +030036
37# Source code repository
38S = "${WORKDIR}/git"
39SRC_URI = "git://github.com/openbmc/phosphor-hostlogger"
Andrew Geissler7b881292019-03-29 06:42:17 +000040SRCREV = "b8cf26fe933c7f020f5195b9575f596b9cb23719"