Eddie James | 1a623ef | 2018-02-09 11:59:18 -0600 | [diff] [blame] | 1 | SUMMARY = "Insecure private key for testing and development" |
| 2 | DESCRIPTION = "Do not use this key to sign images." |
| 3 | PR = "r1" |
Patrick Venture | e931be7 | 2018-11-03 16:33:16 -0700 | [diff] [blame] | 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658" |
Eddie James | 1a623ef | 2018-02-09 11:59:18 -0600 | [diff] [blame] | 6 | |
| 7 | inherit allarch |
| 8 | inherit native |
Eddie James | 1a623ef | 2018-02-09 11:59:18 -0600 | [diff] [blame] | 9 | |
| 10 | SRC_URI += "file://OpenBMC.priv" |
| 11 | |
| 12 | do_install() { |
| 13 | bbplain "Using an insecure image signing key!" |
| 14 | install -d ${D}${datadir} |
| 15 | install -m 400 ${WORKDIR}/OpenBMC.priv ${D}${datadir} |
| 16 | } |