blob: a810faf5835c4b16d0ece16fc6fa1c089110280c [file] [log] [blame]
Cyril Bur9a3f0082017-01-12 18:13:30 +11001SUMMARY = "Phosphor OpenBMC MBOX Daemon"
2DESCRIPTION = "Phosphor OpenBMC MBOX Daemon"
3PR = "r1"
Patrick Venture281a99e2018-10-21 08:26:38 -07004PV = "1.0+git${SRCPV}"
Cyril Bur9a3f0082017-01-12 18:13:30 +11005LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
7
8inherit autotools pkgconfig
9inherit obmc-phosphor-systemd
10
11DEPENDS += "autoconf-archive-native"
Andrew Jeffery928084f2017-04-21 10:18:24 +093012DEPENDS += "systemd"
Patrick Williamsea61a042017-06-30 12:01:49 -050013DEPENDS += "phosphor-logging"
Cyril Bur9a3f0082017-01-12 18:13:30 +110014
15S = "${WORKDIR}/git"
16
Adriana Kobylaka38f5d92018-09-10 11:44:29 -050017SRC_URI += "git://github.com/openbmc/mboxbridge.git"
Cyril Bur9a3f0082017-01-12 18:13:30 +110018
Andrew Jefferya944a4b2017-01-25 13:17:13 +103019SRC_URI += "file://99-aspeed-lpc-ctrl.rules"
Cyril Bur9a3f0082017-01-12 18:13:30 +110020SRC_URI += "file://aspeed-lpc-ctrl-h.patch"
21
Andrew Geissler00a74fa2019-08-07 04:01:19 +000022SRCREV="7e3f20d02f6555d082cdc320790ac8fd9976effb"
Andrew Jefferyaef4ced2017-04-18 16:30:10 +093023
24PROVIDES += "mboxctl"
Cyril Bur9a3f0082017-01-12 18:13:30 +110025
26MBOXD_FLASH_SIZE ??= "32M"
27SYSTEMD_SUBSTITUTIONS += "FLASH_SIZE:${MBOXD_FLASH_SIZE}:${PN}.service"
28
29# Hacks because ${STAGING_KERNEL_DIR} points to the kernel source tree, not the
30# installed, pre-processed headers. Requires the aspeed-lpc-ctrl-h patch above.
Saqib Khanbe0ee8e2017-03-09 10:28:09 -060031CFLAGS_append = " -I include"
Cyril Bur9a3f0082017-01-12 18:13:30 +110032
33do_install_append() {
34 install -d ${D}/lib/udev/rules.d
Andrew Jefferya944a4b2017-01-25 13:17:13 +103035 install -m 0644 ${WORKDIR}/99-aspeed-lpc-ctrl.rules ${D}/lib/udev/rules.d
Cyril Bur9a3f0082017-01-12 18:13:30 +110036}
Matt Spinlerf96194c2017-01-20 15:32:07 -060037
38TMPL = "mboxd-reload@.service"
Andrew Geissler4a9dbb22017-07-25 09:12:37 -050039TGTFMT = "obmc-chassis-poweron@{0}.target"
Matt Spinlerf96194c2017-01-20 15:32:07 -060040INSTFMT = "mboxd-reload@{0}.service"
41FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}"
42
43SYSTEMD_SERVICE_${PN} += "mboxd.service"
44SYSTEMD_SERVICE_${PN} += "mboxd-reload@.service"
45SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
Deepak Kodihallie1aa7fd2017-06-29 09:56:24 -050046
Brad Bishop168ce612018-03-09 00:40:41 -050047# Enable virtual-pnor by DISTRO_FEATURE openpower-ubi-fs.
48PACKAGECONFIG_append_df-openpower-ubi-fs = "virtual-pnor"
Patrick Williams6d641c52017-08-09 16:36:51 -050049PACKAGECONFIG[virtual-pnor] = "--enable-virtual-pnor,--disable-virtual-pnor"