blob: 1c30188083e16768b3670783943fafbf6ee21938 [file] [log] [blame]
Deepak Kodihalli3e3c88c2017-05-17 06:42:51 -05001SUMMARY = "Phosphor Settings Manager"
2DESCRIPTION = "Phosphor Settings Manager is an application that creates \
3d-bus objects to represent various user settings."
4PR = "r1"
5
6inherit autotools
7inherit obmc-phosphor-dbus-service
8inherit pythonnative
9inherit phosphor-settings-manager
10
11require phosphor-settings-manager.inc
12
13DBUS_SERVICE_${PN} = "xyz.openbmc_project.Settings.service"
14
15DEPENDS += "python-pyyaml-native"
16DEPENDS += "python-mako-native"
17DEPENDS += "autoconf-archive-native"
18DEPENDS += "virtual/phosphor-settings-defaults"
19DEPENDS += "sdbusplus sdbusplus-native"
20DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
Deepak Kodihalli36006e72017-06-24 12:56:18 -050021DEPENDS += "cereal"
Deepak Kodihalli3e3c88c2017-05-17 06:42:51 -050022
23RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
24
25S = "${WORKDIR}/git"
26
27EXTRA_OECONF = " \
28 SETTINGS_YAML=${STAGING_DIR_NATIVE}${settings_datadir}/defaults.yaml \
29 "