Brad Bishop | 30f7855 | 2017-01-28 12:51:42 -0500 | [diff] [blame] | 1 | SUMMARY = "Generate inventory map for phosphor-ipmi-fru from an MRW." |
| 2 | PR = "r1" |
| 3 | |
| 4 | inherit native |
| 5 | inherit phosphor-ipmi-fru |
Matt Spinler | 3f6fcbe | 2017-12-14 13:31:55 -0600 | [diff] [blame] | 6 | inherit mrw-xml |
Brad Bishop | 30f7855 | 2017-01-28 12:51:42 -0500 | [diff] [blame] | 7 | |
| 8 | require phosphor-ipmi-fru.inc |
| 9 | |
| 10 | DEPENDS += "mrw-native mrw-perl-tools-native" |
| 11 | |
| 12 | # TODO: remove this dependency after the MRW script |
| 13 | # has been updated to not require the hostfw metadata. |
| 14 | DEPENDS += "virtual/phosphor-ipmi-fru-hostfw-config" |
| 15 | |
| 16 | PROVIDES += "virtual/phosphor-ipmi-fru-inventory" |
| 17 | |
| 18 | S = "${WORKDIR}/git" |
| 19 | do_install() { |
| 20 | |
| 21 | DEST=${D}${config_datadir} |
| 22 | install -d ${DEST} |
| 23 | |
| 24 | ${bindir}/perl-native/perl \ |
| 25 | ${bindir}/gen_ipmi_fru.pl \ |
Matt Spinler | 3f6fcbe | 2017-12-14 13:31:55 -0600 | [diff] [blame] | 26 | -i ${mrw_datadir}/${MRW_XML} \ |
Brad Bishop | 30f7855 | 2017-01-28 12:51:42 -0500 | [diff] [blame] | 27 | -m ${hostfw_datadir}/config.yaml \ |
| 28 | -o ${DEST}/config.yaml |
| 29 | } |