blob: 97da8503dca838c25aa016ffaa7590879d4be5c5 [file] [log] [blame]
Brad Bishopf8a7cd12017-07-09 23:41:49 -04001# Common code for recipes that modify the phosphor-mapper
2# configuration.
3#
4# Typically it is not desired to monitor all dbus traffic
5# on a system and as such, the phosphor-mapper has command
6# line options to control what path namespaces and dbus
7# interfaces it will keep track of.
8#
9# The Phosphor layer by default configures the mapper to
Brad Bishop385c63f2018-10-22 20:48:49 -040010# watch xyz.openbmc_project services, interfaces and paths
11# only. This configuration file is intended to be inherited
12# by native recipes in other layers that wish to add namespaces
Brad Bishopf8a7cd12017-07-09 23:41:49 -040013# or interfaces to the mapper watchlist.
14
15# Add path namespaces to be monitored:
16# PHOSPHOR_MAPPER_NAMESPACE_append = " /foo/bar"
17
Brad Bishop385c63f2018-10-22 20:48:49 -040018# Add service namespaces to be monitored:
19# PHOSPHOR_MAPPER_SERVICE_append = " foo.bar"
20
Brad Bishopf8a7cd12017-07-09 23:41:49 -040021# Add interfaces to be monitored:
22# PHOSPHOR_MAPPER_INTERFACE_append = " foo.bar"
23
Brad Bishop385c63f2018-10-22 20:48:49 -040024# Blacklist services from being monitored:
25# PHOSPHOR_MAPPER_SERVICE_BLACKLIST_append = " foo.bar"
26
Brad Bishopf8a7cd12017-07-09 23:41:49 -040027inherit phosphor-mapperdir
Brad Bishop6f120e32018-03-09 16:51:57 -050028inherit obmc-phosphor-utils
Brad Bishopf8a7cd12017-07-09 23:41:49 -040029
30python phosphor_mapper_do_postinst() {
31 def process_var(d, var, dir):
32 for p in listvar_to_list(d, var):
33 parent = d.getVar('D', True) + d.getVar(dir, True)
34 if not os.path.exists(parent):
35 os.makedirs(parent)
36 path = os.path.join(
37 parent,
Brad Bishopb4eea302017-08-03 15:56:09 -040038 '-'.join(p.split(os.sep)))
Brad Bishopf8a7cd12017-07-09 23:41:49 -040039 with open(path, 'w+') as fd:
40 pass
41
42 process_var(d, 'PHOSPHOR_MAPPER_NAMESPACE', 'namespace_dir')
Brad Bishop385c63f2018-10-22 20:48:49 -040043 process_var(d, 'PHOSPHOR_MAPPER_SERVICE', 'service_dir')
Brad Bishopf8a7cd12017-07-09 23:41:49 -040044 process_var(d, 'PHOSPHOR_MAPPER_INTERFACE', 'interface_dir')
Brad Bishop385c63f2018-10-22 20:48:49 -040045 process_var(d, 'PHOSPHOR_MAPPER_SERVICE_BLACKLIST', 'serviceblacklist_dir')
Brad Bishopf8a7cd12017-07-09 23:41:49 -040046}
47
48do_install[vardeps] += "PHOSPHOR_MAPPER_NAMESPACE"
Brad Bishop385c63f2018-10-22 20:48:49 -040049do_install[vardeps] += "PHOSPHOR_MAPPER_SERVICE"
Brad Bishopf8a7cd12017-07-09 23:41:49 -040050do_install[vardeps] += "PHOSPHOR_MAPPER_INTERFACE"
Brad Bishop385c63f2018-10-22 20:48:49 -040051do_install[vardeps] += "PHOSPHOR_MAPPER_SERVICE_BLACKLIST"
Brad Bishopf8a7cd12017-07-09 23:41:49 -040052do_install[postfuncs] += "phosphor_mapper_do_postinst"