blob: 0e62023da37826afe2598296b2177e8ff28891c5 [file] [log] [blame]
Adriana Kobylak3aeee112018-06-04 13:06:52 -05001# UBI-specific configuration for the phosphor-manager-software package
2
3RDEPENDS_phosphor-software-manager-updater-ubi += " \
4 bash \
5 mtd-utils-ubifs \
6"
7
8FILES_${PN}-updater-ubi += " \
9 ${sbindir}/obmc-flash-bmc \
10 /usr/local \
11 "
12
13SYSTEMD_SERVICE_phosphor-software-manager-updater-ubi += " \
14 obmc-flash-bmc-ubirw.service \
15 obmc-flash-bmc-ubiro@.service \
16 obmc-flash-bmc-setenv@.service \
17 obmc-flash-bmc-ubirw-remove.service \
18 obmc-flash-bmc-ubiro-remove@.service \
19 obmc-flash-bmc-ubiremount.service \
20 obmc-flash-bmc-updateubootvars@.service \
21 obmc-flash-bmc-cleanup.service \
22 obmc-flash-bmc-mirroruboot.service \
23 reboot-guard-enable.service \
24 reboot-guard-disable.service \
25 usr-local.mount \
26"
27
28# Name of the mtd device where the ubi volumes should be created
29BMC_RW_MTD ??= "bmc"
30BMC_RO_MTD ??= "bmc"
31BMC_KERNEL_MTD ??= "bmc"
32BMC_RW_SIZE ??= "0x600000"
33SYSTEMD_SUBSTITUTIONS += "RW_MTD:${BMC_RW_MTD}:obmc-flash-bmc-ubirw.service"
34SYSTEMD_SUBSTITUTIONS += "RO_MTD:${BMC_RO_MTD}:obmc-flash-bmc-ubiro@.service"
35SYSTEMD_SUBSTITUTIONS += "KERNEL_MTD:${BMC_KERNEL_MTD}:obmc-flash-bmc-ubiro@.service"
36SYSTEMD_SUBSTITUTIONS += "RW_SIZE:${BMC_RW_SIZE}:obmc-flash-bmc-ubirw.service"
37
38SRC_URI += "file://obmc-flash-bmc"
39SRC_URI += "file://synclist"
40do_install_append() {
41 install -d ${D}${sbindir}
42 install -m 0755 ${WORKDIR}/obmc-flash-bmc ${D}${sbindir}/obmc-flash-bmc
43 install -d ${D}/usr/local
44
45 if [ -f ${WORKDIR}/build/phosphor-sync-software-manager ]; then
46 install -d ${D}${sysconfdir}
47 install -m 0644 ${WORKDIR}/synclist ${D}${sysconfdir}/synclist
48 fi
49}