blob: 27ed1314b591965a0ad308840a9562228f1d4b18 [file] [log] [blame]
Brad Bishop80fac6d2016-06-07 16:25:54 -04001SUMMARY = "U-Boot bootloader image creation tool"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
4SECTION = "bootloader"
5
6DEPENDS = "openssl"
7
Brad Bishopda482c62016-06-04 00:55:57 -04008SRCREV = "47441cc36bb8e919a066837e4d7c5a8a1c475da4"
Brad Bishop80fac6d2016-06-07 16:25:54 -04009UBRANCH = "v2016.05-ast2500"
10SRC_URI = "git://git@github.com/openbmc/u-boot.git;branch=${UBRANCH};protocol=https"
11
12PV = "v2016.05+git${SRCPV}"
13
14S = "${WORKDIR}/git"
15
16EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1'
17
18do_compile () {
19 oe_runmake sandbox_defconfig
20 oe_runmake cross_tools NO_SDL=1
21}
22
23do_install () {
24 install -d ${D}${bindir}
25 install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
26 ln -sf uboot-mkimage ${D}${bindir}/mkimage
27}
28
29BBCLASSEXTEND = "native nativesdk"