blob: 7be45ec1b1e24223889595626b1311e5e8850686 [file] [log] [blame]
Jayanth Othayoth9963d172017-05-08 09:25:05 -05001SUMMARY = "Phosphor Debug Collector"
2DESCRIPTION = "Phosphor Debug Collector provides mechanisms \
Gunnar Mills2867a482017-08-08 10:53:28 -05003to collect various log files and system parameters. \
Jayanth Othayoth9963d172017-05-08 09:25:05 -05004This will be helpful for troubleshooting the problems in OpenBMC \
5based systems."
6
7PR = "r1"
8
Jayanth Othayoth9d21d6c2017-05-31 06:25:55 -05009DEBUG_COLLECTOR_PKGS = " \
10 ${PN}-manager \
11 ${PN}-monitor \
Jayanth Othayothd2592492017-07-29 22:28:44 -050012 ${PN}-dreport \
Jayanth Othayoth9d21d6c2017-05-31 06:25:55 -050013"
14PACKAGES =+ "${DEBUG_COLLECTOR_PKGS}"
15PACKAGES_remove = "${PN}"
16RDEPENDS_${PN}-dev = "${DEBUG_COLLECTOR_PKGS}"
17RDEPENDS_${PN}-staticdev = "${DEBUG_COLLECTOR_PKGS}"
18
19DBUS_PACKAGES = "${PN}-manager"
20
21SYSTEMD_PACKAGES = "${PN}-monitor"
22
Jayanth Othayoth9963d172017-05-08 09:25:05 -050023inherit autotools \
24 pkgconfig \
Jayanth Othayothaae91e32017-06-05 03:10:00 -050025 obmc-phosphor-dbus-service \
Jayanth Othayoth5f6d8852017-07-05 10:31:16 -050026 pythonnative \
27 phosphor-debug-collector
Jayanth Othayoth9963d172017-05-08 09:25:05 -050028
29require phosphor-debug-collector.inc
30
31DEPENDS += " \
32 phosphor-dbus-interfaces \
33 phosphor-dbus-interfaces-native \
34 phosphor-logging \
35 sdbusplus \
36 sdbusplus-native \
37 autoconf-archive-native \
Jayanth Othayoth9d21d6c2017-05-31 06:25:55 -050038"
Jayanth Othayoth9963d172017-05-08 09:25:05 -050039
Jayanth Othayoth9d21d6c2017-05-31 06:25:55 -050040RDEPENDS_${PN}-manager += " \
Jayanth Othayoth9963d172017-05-08 09:25:05 -050041 sdbusplus \
42 phosphor-dbus-interfaces \
43 phosphor-logging \
Jayanth Othayothd2592492017-07-29 22:28:44 -050044 ${PN}-dreport \
Jayanth Othayoth9d21d6c2017-05-31 06:25:55 -050045"
46RDEPENDS_${PN}-monitor += " \
47 sdbusplus \
48 phosphor-dbus-interfaces \
49 phosphor-logging \
50"
Jayanth Othayothd2592492017-07-29 22:28:44 -050051RDEPENDS_${PN}-dreport += " \
52 systemd \
53 ${VIRTUAL-RUNTIME_base-utils} \
54 bash \
Jayanth Othayoth947c07b2017-07-25 09:29:37 -050055 xz \
Jayanth Othayothd2592492017-07-29 22:28:44 -050056"
Jayanth Othayoth9963d172017-05-08 09:25:05 -050057
Jayanth Othayoth5f6d8852017-07-05 10:31:16 -050058MGR_SVC ?= "xyz.openbmc_project.Dump.Manager.service"
59
60SYSTEMD_SUBSTITUTIONS += "BMC_DUMP_PATH:${bmc_dump_path}:${MGR_SVC}"
61
Jayanth Othayoth9d21d6c2017-05-31 06:25:55 -050062FILES_${PN}-manager += "${sbindir}/phosphor-dump-manager"
63FILES_${PN}-monitor += "${sbindir}/phosphor-dump-monitor"
Jayanth Othayothd2592492017-07-29 22:28:44 -050064FILES_${PN}-dreport += "${bindir}/dreport"
Jayanth Othayoth9d21d6c2017-05-31 06:25:55 -050065
Jayanth Othayoth5f6d8852017-07-05 10:31:16 -050066DBUS_SERVICE_${PN}-manager += "${MGR_SVC}"
Jayanth Othayoth455182a2017-09-12 11:52:08 -050067SYSTEMD_SERVICE_${PN}-monitor += " \
68 obmc-dump-monitor.service \
69 var-lib-systemd-coredump.mount \
70"
Jayanth Othayoth9963d172017-05-08 09:25:05 -050071
Jayanth Othayothf1b85172017-07-05 10:54:35 -050072EXTRA_OECONF = "BMC_DUMP_PATH=${bmc_dump_path}"
Jayanth Othayoth5f6d8852017-07-05 10:31:16 -050073
Jayanth Othayoth9963d172017-05-08 09:25:05 -050074S = "${WORKDIR}/git"
Jayanth Othayothd2592492017-07-29 22:28:44 -050075
76do_install_append() {
77 install -d ${D}${bindir}
78 install -m 0755 ${S}/tools/dreport \
79 ${D}${bindir}/dreport
80}