Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Phosphor State Management" |
| 2 | DESCRIPTION = "Phosphor State Manager provides a set of system state \ |
| 3 | management daemons. It is suitable for use on a wide variety of OpenBMC \ |
| 4 | platforms." |
| 5 | HOMEPAGE = "https://github.com/openbmc/phosphor-state-manager" |
| 6 | PR = "r1" |
| 7 | LICENSE = "Apache-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 9 | |
| 10 | STATE_MGR_PACKAGES = " \ |
| 11 | ${PN}-host \ |
| 12 | ${PN}-chassis \ |
Josh King | a946288 | 2017-01-19 14:04:03 -0600 | [diff] [blame] | 13 | ${PN}-bmc \ |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 14 | " |
| 15 | PACKAGES =+ "${STATE_MGR_PACKAGES}" |
| 16 | DBUS_PACKAGES = "${STATE_MGR_PACKAGES}" |
| 17 | |
| 18 | # Set SYSTEMD_PACKAGES to empty because we do not want ${PN} and DBUS_PACKAGES |
| 19 | # handles the rest. |
| 20 | SYSTEMD_PACKAGES = "" |
| 21 | |
| 22 | inherit autotools pkgconfig |
| 23 | inherit obmc-phosphor-dbus-service |
| 24 | |
| 25 | DEPENDS += "autoconf-archive-native" |
| 26 | DEPENDS += "sdbusplus" |
| 27 | DEPENDS += "phosphor-logging" |
Patrick Williams | d0486d8 | 2017-01-30 11:06:16 -0600 | [diff] [blame] | 28 | DEPENDS += "phosphor-dbus-interfaces" |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 29 | |
Patrick Williams | d0486d8 | 2017-01-30 11:06:16 -0600 | [diff] [blame] | 30 | RDEPENDS_${PN}-host += "libsystemd phosphor-dbus-interfaces" |
| 31 | RDEPENDS_${PN}-chassis += "libsystemd phosphor-dbus-interfaces" |
| 32 | RDEPENDS_${PN}-bmc += "libsystemd phosphor-dbus-interfaces" |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 33 | |
| 34 | PROVIDES += "virtual/obmc-host-state-mgmt" |
| 35 | RPROVIDES_${PN}-host += "virtual-obmc-host-state-mgmt" |
| 36 | FILES_${PN}-host = "${sbindir}/phosphor-host-state-manager" |
| 37 | DBUS_SERVICE_${PN}-host += "xyz.openbmc_project.State.Host.service" |
| 38 | |
| 39 | PROVIDES += "virtual/obmc-chassis-state-mgmt" |
| 40 | RPROVIDES_${PN}-chassis += "virtual-obmc-chassis-state-mgmt" |
| 41 | FILES_${PN}-chassis = "${sbindir}/phosphor-chassis-state-manager" |
| 42 | DBUS_SERVICE_${PN}-chassis += "xyz.openbmc_project.State.Chassis.service" |
| 43 | |
Josh King | a946288 | 2017-01-19 14:04:03 -0600 | [diff] [blame] | 44 | PROVIDES += "virtual/obmc-bmc-state-mgmt" |
| 45 | RPROVIDES_${PN}-bmc += "virtual-obmc-bmc-state-mgmt" |
| 46 | FILES_${PN}-bmc = "${sbindir}/phosphor-bmc-state-manager" |
| 47 | DBUS_SERVICE_${PN}-bmc += "xyz.openbmc_project.State.BMC.service" |
| 48 | |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 49 | SRC_URI += "git://github.com/openbmc/phosphor-state-manager" |
Patrick Williams | 6aa5e5f | 2017-01-31 10:30:03 -0600 | [diff] [blame] | 50 | SRCREV = "515f74bc03b0e8242c939da79b6718a253256abe" |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 51 | |
| 52 | S = "${WORKDIR}/git" |