blob: 2f9d7c184a7105f256dec1a4a7852445d1e7b7fc [file] [log] [blame]
Patrick Venturedb1cc9b2018-09-20 19:27:13 -07001HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-blobs"
2SUMMARY = "Phosphor OEM IPMI BLOBS Protocol Implementation"
3DESCRIPTION = "This package handles a series of OEM IPMI commands that implement the BLOB protocol for sending and receiving data over IPMI."
4PR = "r1"
5PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9inherit autotools pkgconfig
10inherit obmc-phosphor-ipmiprovider-symlink
11
12DEPENDS += "autoconf-archive-native"
13DEPENDS += "phosphor-ipmi-host"
Patrick Venture2b120942018-09-27 12:56:49 -070014DEPENDS += "phosphor-logging"
Patrick Venturea007bef2019-03-07 10:53:50 -080015DEPENDS += "ipmi-blob-tool"
Patrick Venturedb1cc9b2018-09-20 19:27:13 -070016
17S = "${WORKDIR}/git"
18SRC_URI = "git://github.com/openbmc/phosphor-ipmi-blobs"
Andrew Geissler0bd4a792020-11-04 21:51:24 +000019SRCREV = "99f25beb8cfb8a6704f2648ec47f066907403e55"
Patrick Venturedb1cc9b2018-09-20 19:27:13 -070020
21FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
22FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
23FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
24FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
25
26HOSTIPMI_PROVIDER_LIBRARY += "libblobcmds.so"