Lei YU | 2172cd1 | 2020-02-06 15:43:35 +0800 | [diff] [blame] | 1 | SUMMARY = "Phosphor Power Sequencer services installation" |
| 2 | PR = "r1" |
| 3 | |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 6 | |
| 7 | inherit allarch |
| 8 | |
| 9 | RDEPENDS_${PN} += "phosphor-power-sequencer" |
| 10 | |
| 11 | ALLOW_EMPTY_${PN} = "1" |
| 12 | |
| 13 | pkg_postinst_${PN}() { |
| 14 | mkdir -p $D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants |
| 15 | mkdir -p $D$systemd_system_unitdir/multi-user.target.requires |
| 16 | |
| 17 | LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants/pseq-monitor.service" |
| 18 | TARGET="../pseq-monitor.service" |
| 19 | ln -s $TARGET $LINK |
| 20 | |
| 21 | LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants/pseq-monitor-pgood.service" |
| 22 | TARGET="../pseq-monitor-pgood.service" |
| 23 | ln -s $TARGET $LINK |
| 24 | } |
| 25 | |
| 26 | pkg_prerm_${PN}() { |
| 27 | LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants/pseq-monitor.service" |
| 28 | rm $LINK |
| 29 | LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants/pseq-monitor-pgood.service" |
| 30 | rm $LINK |
| 31 | } |