blob: 3a7d1ef11ee148a24c98f8c01e8e84617832b29f [file] [log] [blame]
Vijay Khemka55cd7052020-10-08 16:36:28 -07001SUMMARY = "Virtual Sensors"
2DESCRIPTION = "virtual sensors created from existing sensors and config data"
3HOMEPAGE = "https://github.com/openbmc/phosphor-virtual-sensor"
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=9e69ba356fa59848ffd865152a3ccc13"
7
8inherit meson pkgconfig
9inherit systemd
10
11DEPENDS += "sdbusplus"
12DEPENDS += "phosphor-dbus-interfaces"
13DEPENDS += "sdeventplus"
14DEPENDS += "phosphor-logging"
15DEPENDS += "nlohmann-json"
16DEPENDS += "exprtk"
17
18SRC_URI = "git://github.com/openbmc/phosphor-virtual-sensor.git;protocol=git"
Andrew Geisslerdf627fe2021-01-12 23:01:44 +000019SRCREV = "6c19e7d2b6e5cf1502a1ded8d7e42a452ca766f1"
Vijay Khemka55cd7052020-10-08 16:36:28 -070020S = "${WORKDIR}/git"
21
22SYSTEMD_SERVICE_${PN} = "phosphor-virtual-sensor.service"