Gunnar Mills | 4c31bf6 | 2018-02-12 16:29:16 -0600 | [diff] [blame] | 1 | # Overriding map_nodejs_arch() is needed to support building nodejs on ppc64le |
| 2 | # We can remove this, once OpenBMC moves to a version of Yocto with |
| 3 | # http://lists.openembedded.org/pipermail/openembedded-devel/2018-February/116737.html |
| 4 | def map_nodejs_arch(a, d): |
| 5 | import re |
| 6 | |
| 7 | if re.match('i.86$', a): return 'ia32' |
| 8 | elif re.match('x86_64$', a): return 'x64' |
| 9 | elif re.match('aarch64$', a): return 'arm64' |
| 10 | elif re.match('(powerpc64|ppc64le)$', a): return 'ppc64' |
| 11 | elif re.match('powerpc$', a): return 'ppc' |
| 12 | return a |