blob: a780621cdf807d4a54fbfcc588294e289c22d5f4 [file] [log] [blame]
Vijay Khemka55cd7052020-10-08 16:36:28 -07001SUMMARY = "Virtual Sensors"
2DESCRIPTION = "virtual sensors created from existing sensors and config data"
3HOMEPAGE = "https://github.com/openbmc/phosphor-virtual-sensor"
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=9e69ba356fa59848ffd865152a3ccc13"
7
8inherit meson pkgconfig
9inherit systemd
10
11DEPENDS += "sdbusplus"
12DEPENDS += "phosphor-dbus-interfaces"
13DEPENDS += "sdeventplus"
14DEPENDS += "phosphor-logging"
15DEPENDS += "nlohmann-json"
16DEPENDS += "exprtk"
17
18SRC_URI = "git://github.com/openbmc/phosphor-virtual-sensor.git;protocol=git"
Andrew Geissler46ead4c2020-11-05 17:11:40 +000019SRCREV = "e0d371e41f0bcbb28fcc2dc634b4d903cf6a610a"
Vijay Khemka55cd7052020-10-08 16:36:28 -070020S = "${WORKDIR}/git"
21
22SYSTEMD_SERVICE_${PN} = "phosphor-virtual-sensor.service"