Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 1 | SUMMARY = "OpenBMC org.openbmc.control.Chassis example implementation" |
| 2 | DESCRIPTION = "An example implementation of the org.openbmc.control.Chassis DBUS API." |
| 3 | PR = "r1" |
| 4 | |
| 5 | inherit skeleton-python |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 6 | inherit obmc-phosphor-dbus-service |
Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 7 | |
| 8 | RDEPENDS_${PN} += "\ |
| 9 | python-dbus \ |
| 10 | python-pygobject \ |
| 11 | python-netclient \ |
Brad Bishop | 1b4e447 | 2016-08-29 21:47:04 -0400 | [diff] [blame] | 12 | pyphosphor-dbus \ |
Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 13 | " |
| 14 | |
| 15 | SKELETON_DIR = "pychassisctl" |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 16 | |
| 17 | FMT = "org.openbmc.control.Chassis@{0}.service" |
| 18 | DBUS_SERVICE_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}" |