Deepak Kodihalli | 44b1c52 | 2017-03-16 06:32:12 -0500 | [diff] [blame] | 1 | SUMMARY = "Generated callout information for phosphor-logging" |
| 2 | PR = "r1" |
| 3 | |
| 4 | inherit native |
| 5 | inherit obmc-phosphor-license |
| 6 | inherit phosphor-logging |
Matt Spinler | 3f6fcbe | 2017-12-14 13:31:55 -0600 | [diff] [blame] | 7 | inherit mrw-xml |
Deepak Kodihalli | 44b1c52 | 2017-03-16 06:32:12 -0500 | [diff] [blame] | 8 | |
| 9 | DEPENDS += " \ |
| 10 | mrw-native \ |
| 11 | mrw-perl-tools-native \ |
| 12 | " |
| 13 | |
| 14 | PROVIDES += "virtual/phosphor-logging-callouts" |
| 15 | |
| 16 | S = "${WORKDIR}" |
| 17 | |
| 18 | do_install() { |
| 19 | DEST=${D}${callouts_datadir} |
| 20 | install -d ${DEST} |
| 21 | |
| 22 | ${bindir}/perl-native/perl \ |
| 23 | ${bindir}/gen_callouts.pl \ |
Matt Spinler | 3f6fcbe | 2017-12-14 13:31:55 -0600 | [diff] [blame] | 24 | -m ${mrw_datadir}/${MRW_XML} \ |
Deepak Kodihalli | 44b1c52 | 2017-03-16 06:32:12 -0500 | [diff] [blame] | 25 | -o ${DEST}/callouts.yaml |
| 26 | } |