blob: 6fe3bdee1fa19bc451f2a4a25c4276cd1aee5728 [file] [log] [blame]
Jeremy Kerr49208ee2016-03-17 17:35:27 +08001SUMMARY = "OpenBMC console daemon"
2DESCRIPTION = "Daemon to handle UART console connections"
3HOMEPAGE = "http://github.com/openbmc/obmc-console"
4PR = "r1"
5
6inherit obmc-phosphor-license
7inherit obmc-phosphor-systemd
8inherit autotools
9
10TARGET_CFLAGS += "-fpic -O2"
11
12SRC_URI += "git://github.com/openbmc/obmc-console"
13SRC_URI += "file://${PN}.conf"
14SRCREV = "54e9569d14b127806e45e1c17ec4a1f5f7271d3f"
15
16do_install_append() {
17 install -m 0755 -d ${D}${sysconfdir}
18 install -m 0644 ${WORKDIR}/${PN}.conf ${D}${sysconfdir}/${PN}.conf
19}
20
21S = "${WORKDIR}/git"