blob: 80715e7c11403bc966f1442fad03b5ebd5920d7d [file] [log] [blame]
Brad Bishop0028d5a2015-10-08 15:15:52 -04001require recipes-bsp/u-boot/u-boot.inc
2
3# To build u-boot for your machine, provide the following lines in your machine
4# config, replacing the assignments as appropriate for your machine.
5# UBOOT_MACHINE = "omap3_beagle_config"
6# UBOOT_ENTRYPOINT = "0x80008000"
7# UBOOT_LOADADDRESS = "0x80008000"
8
9LICENSE = "GPLv2+"
10LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
11 file://README;beginline=1;endline=22;md5=78b195c11cb6ef63e6985140db7d7bab"
12
13# This revision corresponds to the tag "v2013.07"
14# We use the revision in order to avoid having to fetch it from the repo during parse
Chris Austen49887062016-01-19 14:45:55 -060015SRCREV = "${AUTOREV}"
Brad Bishop0028d5a2015-10-08 15:15:52 -040016
17PV = "v2013.07+git${SRCPV}"
18
Chris Austen49887062016-01-19 14:45:55 -060019UBRANCH = "v2013.07-aspeed-openbmc"
20SRC_URI = "git://git@github.com/openbmc/u-boot.git;branch=${UBRANCH};protocol=https"
Brad Bishop0028d5a2015-10-08 15:15:52 -040021
22S = "${WORKDIR}/git"
23
24PACKAGE_ARCH = "${MACHINE_ARCH}"