Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 1 | SUMMARY = "OpenBMC system manager" |
| 2 | DESCRIPTION = "OpenBMC system manager." |
| 3 | PR = "r1" |
| 4 | |
| 5 | inherit skeleton-python |
| 6 | inherit obmc-phosphor-systemd |
| 7 | |
| 8 | VIRTUAL-RUNTIME_skeleton_workbook ?= "" |
| 9 | |
| 10 | RDEPENDS_${PN} += "\ |
| 11 | python-dbus \ |
| 12 | python-json \ |
| 13 | python-subprocess \ |
| 14 | python-pygobject \ |
| 15 | pyphosphor \ |
| 16 | ${VIRTUAL-RUNTIME_skeleton_workbook} \ |
| 17 | " |
| 18 | |
| 19 | SKELETON_DIR = "pysystemmgr" |
| 20 | |
| 21 | do_compile_append() { |
| 22 | oe_runmake -C ../hacks |
| 23 | } |
| 24 | |
| 25 | do_install_append() { |
| 26 | oe_runmake -C ../hacks install DESTDIR=${D} |
| 27 | } |