blob: 8572add08499625b58ac9859dbb940bd3eef5647 [file] [log] [blame]
Brad Bishop4aa3a502015-10-29 23:35:38 -05001SUMMARY = "Phosphor OpenBMC BT to DBUS"
2DESCRIPTION = "Phosphor OpenBMC BT to DBUS."
3PR = "r1"
4
5inherit obmc-phosphor-sdbus-service
6inherit obmc-phosphor-c-daemon
7
8SYSTEMD_SERVICE_${PN} = "btbridged.service"
9
10inherit obmc-phosphor-host-ipmi-hw
11
12S = "${WORKDIR}/git"
13SRC_URI += "git://github.com/openbmc/btbridge file://makefile.patch"
14SRCREV="5cb9032815aa9d2866229caac4943520d5f40dd8"
15
16# This is how linux-libc-headers says to include custom uapi headers
17EXTRA_OEMAKE_append = "CFLAGS=-I${STAGING_KERNEL_DIR}/include/uapi"
18DEPENDS += "virtual/kernel"