Eddie James | 1a623ef | 2018-02-09 11:59:18 -0600 | [diff] [blame] | 1 | SUMMARY = "Insecure private key for testing and development" |
2 | DESCRIPTION = "Do not use this key to sign images." | ||||
3 | PR = "r1" | ||||
4 | |||||
5 | inherit allarch | ||||
6 | inherit native | ||||
7 | inherit obmc-phosphor-license | ||||
8 | |||||
9 | SRC_URI += "file://OpenBMC.priv" | ||||
10 | |||||
11 | do_install() { | ||||
12 | bbplain "Using an insecure image signing key!" | ||||
13 | install -d ${D}${datadir} | ||||
14 | install -m 400 ${WORKDIR}/OpenBMC.priv ${D}${datadir} | ||||
15 | } |