Brad Bishop | 80fac6d | 2016-06-07 16:25:54 -0400 | [diff] [blame] | 1 | SUMMARY = "U-Boot bootloader image creation tool" |
| 2 | LICENSE = "GPLv2+" |
Brad Bishop | 80fac6d | 2016-06-07 16:25:54 -0400 | [diff] [blame] | 3 | SECTION = "bootloader" |
| 4 | |
| 5 | DEPENDS = "openssl" |
| 6 | |
Patrick Williams | 395dcbc | 2017-06-26 14:49:59 -0500 | [diff] [blame] | 7 | require u-boot.inc |
Brad Bishop | 80fac6d | 2016-06-07 16:25:54 -0400 | [diff] [blame] | 8 | |
| 9 | S = "${WORKDIR}/git" |
| 10 | |
| 11 | EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1' |
| 12 | |
| 13 | do_compile () { |
| 14 | oe_runmake sandbox_defconfig |
| 15 | oe_runmake cross_tools NO_SDL=1 |
| 16 | } |
| 17 | |
| 18 | do_install () { |
| 19 | install -d ${D}${bindir} |
| 20 | install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage |
| 21 | ln -sf uboot-mkimage ${D}${bindir}/mkimage |
| 22 | } |
| 23 | |
| 24 | BBCLASSEXTEND = "native nativesdk" |