blob: 7f4043524dfcaf5610bf4c60ef999bf99f80cfd6 [file] [log] [blame]
Brad Bishop80fac6d2016-06-07 16:25:54 -04001SUMMARY = "U-Boot bootloader image creation tool"
2LICENSE = "GPLv2+"
Brad Bishop80fac6d2016-06-07 16:25:54 -04003SECTION = "bootloader"
4
5DEPENDS = "openssl"
6
Patrick Williams395dcbc2017-06-26 14:49:59 -05007require u-boot.inc
Brad Bishop80fac6d2016-06-07 16:25:54 -04008
9S = "${WORKDIR}/git"
10
11EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1'
12
13do_compile () {
14 oe_runmake sandbox_defconfig
15 oe_runmake cross_tools NO_SDL=1
16}
17
18do_install () {
19 install -d ${D}${bindir}
20 install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
21 ln -sf uboot-mkimage ${D}${bindir}/mkimage
22}
23
24BBCLASSEXTEND = "native nativesdk"