blob: 284369d6546916ae3182bd985602612ab66152b7 [file] [log] [blame]
Ratan Guptab92d0ec2017-03-06 17:05:11 +05301SUMMARY = "sensor config for phosphor-host-ipmid"
2PR = "r1"
3
4inherit native
5inherit obmc-phosphor-license
6inherit phosphor-ipmi-host
7
8SRC_URI += "file://config.yaml"
9
10DEPENDS += " \
11 mrw-native \
12 mrw-perl-tools-native \
13 "
14
15PROVIDES += "virtual/phosphor-ipmi-sensor-inventory"
16
17S = "${WORKDIR}"
18
19do_install() {
20 DEST=${D}${config_datadir}
21 install -d ${DEST}
22
23 ${bindir}/perl-native/perl \
24 ${bindir}/gen_ipmi_sensor.pl \
25 -i ${datadir}/obmc-mrw/${MACHINE}.xml \
26 -m config.yaml \
27 -o ${DEST}/sensor.yaml
28}