blob: 0c512fcb45e1700be2facadb25f7b2f7408ff30d [file] [log] [blame]
Brad Bishop30f78552017-01-28 12:51:42 -05001SUMMARY = "Generate inventory map for phosphor-ipmi-fru from an MRW."
2PR = "r1"
3
4inherit native
5inherit phosphor-ipmi-fru
6
7require phosphor-ipmi-fru.inc
8
9DEPENDS += "mrw-native mrw-perl-tools-native"
10
11# TODO: remove this dependency after the MRW script
12# has been updated to not require the hostfw metadata.
13DEPENDS += "virtual/phosphor-ipmi-fru-hostfw-config"
14
15PROVIDES += "virtual/phosphor-ipmi-fru-inventory"
16
17S = "${WORKDIR}/git"
18do_install() {
19
20 DEST=${D}${config_datadir}
21 install -d ${DEST}
22
23 ${bindir}/perl-native/perl \
24 ${bindir}/gen_ipmi_fru.pl \
25 -i ${datadir}/obmc-mrw/${MACHINE}.xml \
26 -m ${hostfw_datadir}/config.yaml \
27 -o ${DEST}/config.yaml
28}