Joel Stanley | 79d1653 | 2016-03-21 12:24:40 +1030 | [diff] [blame] | 1 | DESCRIPTION = "Linux kernel for OpenBMC" |
| 2 | SECTION = "kernel" |
| 3 | LICENSE = "GPLv2" |
| 4 | |
| 5 | KBRANCH ?= "dev-4.4" |
| 6 | KCONFIG_MODE="--alldefconfig" |
| 7 | |
| 8 | SRC_URI = "git://github.com/openbmc/linux;protocol=git;branch=${KBRANCH}" |
| 9 | |
| 10 | LINUX_VERSION ?= "4.4" |
| 11 | LINUX_VERSION_EXTENSION ?= "-${SRCREV}" |
| 12 | |
| 13 | SRCREV="openbmc-20160329-2" |
| 14 | |
| 15 | PV = "${LINUX_VERSION}+git${SRCPV}" |
| 16 | |
| 17 | COMPATIBLE_MACHINE_${MACHINE} = "openbmc" |
| 18 | |
| 19 | inherit kernel |
| 20 | require recipes-kernel/linux/linux-yocto.inc |