Brad Bishop | 0e27f20 | 2017-07-22 14:49:25 -0400 | [diff] [blame] | 1 | # IMAGE_FSTYPES must appear before image.bbclass |
| 2 | # is inherited otherwise image.bbclass will inherit |
| 3 | # "live" image fstypes that we don't want. |
| 4 | IMAGE_FSTYPES = "tar.xz" |
| 5 | |
Patrick Williams | 41ee597 | 2016-08-05 15:05:16 -0500 | [diff] [blame] | 6 | inherit image |
| 7 | inherit obmc-phosphor-license |
| 8 | |
Patrick Williams | d01c718 | 2016-08-15 15:26:38 -0500 | [diff] [blame] | 9 | IMAGE_INSTALL_append = " busybox packagegroup-obmc-phosphor-debugtools" |
Patrick Williams | 41ee597 | 2016-08-05 15:05:16 -0500 | [diff] [blame] | 10 | |
| 11 | # Override from image_types.bbclass to restrict tarball to /usr tree. |
Saqib Khan | 644da5d | 2017-03-09 10:18:56 -0600 | [diff] [blame] | 12 | IMAGE_CMD_tar = "${IMAGE_CMD_TAR} -cvf ${IMGDEPLOYDIR}/${IMAGE_NAME}${IMAGE_NAME_SUFFIX}.tar -C ${IMAGE_ROOTFS}/usr ." |
Patrick Williams | 41ee597 | 2016-08-05 15:05:16 -0500 | [diff] [blame] | 13 | |
| 14 | # Remove packages installed by 'extrausers'. |
| 15 | IMAGE_INSTALL_remove = "base-passwd shadow" |
| 16 | EXTRA_USERS_PARAMS = "" |
| 17 | |
| 18 | # Remove extra packages defaulted by image.bbclass. |
| 19 | PACKAGE_INSTALL = "${IMAGE_INSTALL}" |
| 20 | IMAGE_LINGUAS = "" |