Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Phosphor State Management" |
| 2 | DESCRIPTION = "Phosphor State Manager provides a set of system state \ |
| 3 | management daemons. It is suitable for use on a wide variety of OpenBMC \ |
| 4 | platforms." |
| 5 | HOMEPAGE = "https://github.com/openbmc/phosphor-state-manager" |
| 6 | PR = "r1" |
| 7 | LICENSE = "Apache-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 9 | |
| 10 | STATE_MGR_PACKAGES = " \ |
| 11 | ${PN}-host \ |
| 12 | ${PN}-chassis \ |
| 13 | " |
| 14 | PACKAGES =+ "${STATE_MGR_PACKAGES}" |
| 15 | DBUS_PACKAGES = "${STATE_MGR_PACKAGES}" |
| 16 | |
| 17 | # Set SYSTEMD_PACKAGES to empty because we do not want ${PN} and DBUS_PACKAGES |
| 18 | # handles the rest. |
| 19 | SYSTEMD_PACKAGES = "" |
| 20 | |
| 21 | inherit autotools pkgconfig |
| 22 | inherit obmc-phosphor-dbus-service |
| 23 | |
| 24 | DEPENDS += "autoconf-archive-native" |
| 25 | DEPENDS += "sdbusplus" |
| 26 | DEPENDS += "phosphor-logging" |
| 27 | |
| 28 | RDEPENDS_${PN}-host += "libsystemd" |
| 29 | RDEPENDS_${PN}-chassis += "libsystemd" |
| 30 | |
| 31 | PROVIDES += "virtual/obmc-host-state-mgmt" |
| 32 | RPROVIDES_${PN}-host += "virtual-obmc-host-state-mgmt" |
| 33 | FILES_${PN}-host = "${sbindir}/phosphor-host-state-manager" |
| 34 | DBUS_SERVICE_${PN}-host += "xyz.openbmc_project.State.Host.service" |
| 35 | |
| 36 | PROVIDES += "virtual/obmc-chassis-state-mgmt" |
| 37 | RPROVIDES_${PN}-chassis += "virtual-obmc-chassis-state-mgmt" |
| 38 | FILES_${PN}-chassis = "${sbindir}/phosphor-chassis-state-manager" |
| 39 | DBUS_SERVICE_${PN}-chassis += "xyz.openbmc_project.State.Chassis.service" |
| 40 | |
| 41 | SRC_URI += "git://github.com/openbmc/phosphor-state-manager" |
| 42 | SRCREV = "6e0b50936735faac96db2f20fe84ffd0733750a9" |
| 43 | |
| 44 | S = "${WORKDIR}/git" |