blob: e7a6d7ecab2f1a5a23846f71df06cdf8aa1f4a10 [file] [log] [blame]
Brad Bishop2c5ba172017-04-22 16:26:22 -04001SUMMARY = "Phosphor Fan"
2DESCRIPTION = "Phosphor fan provides a set of fan monitoring and \
3control applications."
4PR = "r1"
5
6require ${PN}.inc
7
8inherit autotools pkgconfig pythonnative
9inherit obmc-phosphor-systemd
10inherit phosphor-fan
11
12S = "${WORKDIR}/git"
13
14# Common build dependencies
15DEPENDS += "autoconf-archive-native"
16DEPENDS += "python-pyyaml-native"
17DEPENDS += "python-mako-native"
18DEPENDS += "sdbusplus"
19DEPENDS += "phosphor-logging"
20
21# Package configuration
22FAN_PACKAGES = " \
23 ${PN}-presence-tach \
24 ${PN}-control \
Matt Spinler39652c82017-05-01 14:29:20 -050025 ${PN}-monitor \
Brad Bishop2c5ba172017-04-22 16:26:22 -040026 phosphor-chassis-cooling-type \
27"
28PACKAGES_remove = "${PN}"
29PACKAGES += "${FAN_PACKAGES}"
Matt Spinler39652c82017-05-01 14:29:20 -050030PACKAGECONFIG ??= "presence control cooling-type monitor"
Brad Bishop2c5ba172017-04-22 16:26:22 -040031SYSTEMD_PACKAGES = "${FAN_PACKAGES}"
32RDEPENDS_${PN}-dev = "${FAN_PACKAGES}"
33RDEPENDS_${PN}-staticdev = "${FAN_PACKAGES}"
34
35# --------------------------------------
36# ${PN}-presence-tach specific configuration
37PACKAGECONFIG[presence] = " \
38 --enable-presence \
Brad Bishop9fb4ce62017-05-25 14:28:04 -040039 FAN_DETECT_YAML_FILE=${STAGING_DIR_NATIVE}${presence_datadir}/config.yaml, \
Brad Bishop2c5ba172017-04-22 16:26:22 -040040 --disable-presence, \
41 virtual/phosphor-fan-presence-config \
42 , \
43"
44RDEPENDS_${PN}-presence-tach += "sdbusplus"
45
Matt Spinlerbd9fdd92017-04-19 08:23:50 -050046# Needed to install into the obmc-chassis-poweron target
47TMPL_TACH = "phosphor-fan-presence-tach@.service"
48INSTFMT_TACH = "phosphor-fan-presence-tach@{0}.service"
Matt Spinler29feaa32017-05-16 10:49:57 -050049POWERON_TGT = "obmc-chassis-poweron@{0}.target"
50FMT_TACH = "../${TMPL_TACH}:${POWERON_TGT}.requires/${INSTFMT_TACH}"
Brad Bishop2c5ba172017-04-22 16:26:22 -040051
52FILES_${PN}-presence-tach = "${sbindir}/phosphor-fan-presence-tach"
Matt Spinlerbd9fdd92017-04-19 08:23:50 -050053SYSTEMD_SERVICE_${PN}-presence-tach += "${TMPL_TACH}"
54SYSTEMD_LINK_${PN}-presence-tach += "${@compose_list(d, 'FMT_TACH', 'OBMC_CHASSIS_INSTANCES')}"
Brad Bishop2c5ba172017-04-22 16:26:22 -040055
56# --------------------------------------
57# ${PN}-control specific configuration
Matt Spinlerbd9fdd92017-04-19 08:23:50 -050058PACKAGECONFIG[control] = "--enable-control \
59 FAN_DEF_YAML_FILE=${STAGING_DIR_NATIVE}${control_datadir}/fans.yaml \
60 FAN_ZONE_YAML_FILE=${STAGING_DIR_NATIVE}${control_datadir}/zones.yaml \
Matthew Barth5f26abf2017-05-24 17:06:13 -050061 ZONE_EVENTS_YAML_FILE=${STAGING_DIR_NATIVE}${control_datadir}/events.yaml \
Matt Spinlerbd9fdd92017-04-19 08:23:50 -050062 FAN_ZONE_OUTPUT_DIR=${S}/control, \
63 --disable-control, \
64 virtual/phosphor-fan-control-fan-config \
65 phosphor-fan-control-zone-config-native \
Matthew Barth5f26abf2017-05-24 17:06:13 -050066 phosphor-fan-control-events-config-native \
Matt Spinlerbd9fdd92017-04-19 08:23:50 -050067 , \
68"
69
70RDEPENDS_${PN}-control += "sdbusplus"
71
Matt Spinler29feaa32017-05-16 10:49:57 -050072FAN_CONTROL_TGT = "obmc-fan-control-ready@{0}.target"
73
Matt Spinlerbd9fdd92017-04-19 08:23:50 -050074TMPL_CONTROL = "phosphor-fan-control@.service"
75INSTFMT_CONTROL = "phosphor-fan-control@{0}.service"
Matt Spinler29feaa32017-05-16 10:49:57 -050076FMT_CONTROL = "../${TMPL_CONTROL}:${FAN_CONTROL_TGT}.requires/${INSTFMT_CONTROL}"
77
78TMPL_CONTROL_INIT = "phosphor-fan-control-init@.service"
79INSTFMT_CONTROL_INIT = "phosphor-fan-control-init@{0}.service"
80FMT_CONTROL_INIT = "../${TMPL_CONTROL_INIT}:${POWERON_TGT}.requires/${INSTFMT_CONTROL_INIT}"
Matt Spinlerbd9fdd92017-04-19 08:23:50 -050081
Brad Bishop2c5ba172017-04-22 16:26:22 -040082FILES_${PN}-control = "${sbindir}/phosphor-fan-control"
Matt Spinler29feaa32017-05-16 10:49:57 -050083SYSTEMD_SERVICE_${PN}-control += "${TMPL_CONTROL} ${TMPL_CONTROL_INIT}"
Matt Spinlerbd9fdd92017-04-19 08:23:50 -050084SYSTEMD_LINK_${PN}-control += "${@compose_list(d, 'FMT_CONTROL', 'OBMC_CHASSIS_INSTANCES')}"
Matt Spinler29feaa32017-05-16 10:49:57 -050085SYSTEMD_LINK_${PN}-control += "${@compose_list(d, 'FMT_CONTROL_INIT', 'OBMC_CHASSIS_INSTANCES')}"
Brad Bishop2c5ba172017-04-22 16:26:22 -040086
87# --------------------------------------
88# phosphor-chassis-cooling-type specific configuration
89PACKAGECONFIG[cooling-type] = "--enable-cooling-type,--disable-cooling-type,libevdev,"
90RDEPENDS_phosphor-chassis-cooling-type += "libevdev"
91FILES_phosphor-chassis-cooling-type = "${sbindir}/phosphor-cooling-type"
Matt Spinler39652c82017-05-01 14:29:20 -050092
93# --------------------------------------
94# ${PN}-monitor specific configuration
95PACKAGECONFIG[monitor] = "--enable-monitor \
96 FAN_MONITOR_YAML_FILE=${STAGING_DIR_NATIVE}${monitor_datadir}/monitor.yaml \
97 FAN_MONITOR_OUTPUT_DIR=${S}/monitor, \
98 --disable-monitor, \
99 phosphor-fan-monitor-config-native \
100 , \
101"
102
103RDEPENDS_${PN}-monitor += "sdbusplus"
104
105TMPL_MONITOR = "phosphor-fan-monitor@.service"
106INSTFMT_MONITOR = "phosphor-fan-monitor@{0}.service"
Matt Spinler29feaa32017-05-16 10:49:57 -0500107FMT_MONITOR = "../${TMPL_MONITOR}:${FAN_CONTROL_TGT}.requires/${INSTFMT_MONITOR}"
Matt Spinler39652c82017-05-01 14:29:20 -0500108
109FILES_${PN}-monitor = "${sbindir}/phosphor-fan-monitor"
110SYSTEMD_SERVICE_${PN}-monitor += "${TMPL_MONITOR}"
111SYSTEMD_LINK_${PN}-monitor += "${@compose_list(d, 'FMT_MONITOR', 'OBMC_CHASSIS_INSTANCES')}"