blob: 42faa60ffaba06a858aba158aedef9ddb129b4d3 [file] [log] [blame]
Artem Senichev8135af92018-11-02 16:46:13 +03001SUMMARY = "Phosphor Host logger"
2DESCRIPTION = "Save log messages from host's console to the persistent storage."
3HOMEPAGE = "https://github.com/openbmc/phosphor-hostlogger"
4PR = "r1"
5PV = "1.0+git${SRCPV}"
6
7inherit autotools
8inherit pkgconfig
9inherit pythonnative
10inherit systemd
11
12# License info
13LICENSE = "Apache-2.0"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
15
16# Dependencies
Alexander Filippov74dc8702019-01-10 12:38:09 +030017DEPENDS += "\
18 autoconf-archive-native \
19 sdbusplus \
Artem Senichev8135af92018-11-02 16:46:13 +030020 sdbusplus-native \
Alexander Filippov74dc8702019-01-10 12:38:09 +030021 phosphor-dbus-interfaces \
22 "
Artem Senichev8135af92018-11-02 16:46:13 +030023RDEPENDS_${PN} += "obmc-console"
24RRECOMMENDS_${PN} += "phosphor-debug-collector"
25
26# systemd service setup
27SYSTEMD_PACKAGES = "${PN}"
28SYSTEMD_SERVICE_${PN} = "hostlogger.service"
29SYSTEMD_DEFAULT_TARGET ?= "multi-user.target"
30
31# Host TTY setup
32OBMC_CONSOLE_HOST_TTY ?= "ttyVUART0"
33
34# Extra parameters for 'configure' script
35EXTRA_OECONF = "HOST_TTY=${OBMC_CONSOLE_HOST_TTY} \
36 SYSTEMD_TARGET=${SYSTEMD_DEFAULT_TARGET}"
37
38# Source code repository
39S = "${WORKDIR}/git"
40SRC_URI = "git://github.com/openbmc/phosphor-hostlogger"
Andrew Geisslera2c584b2019-02-14 07:42:17 +000041SRCREV = "f780288ad8ce72e4ff924dada1c996ad1bddb2b8"