blob: 184127f15f7a7732b5ed02e45d3b3c6a77543327 [file] [log] [blame]
Brad Bishopf1cc41b2017-05-31 14:08:33 -04001SUMMARY = "Phosphor DBus Monitor"
2DESCRIPTION = "Phosphor DBus Monitor is a general purpose DBus application \
3that watches DBus traffic for events and takes actions based on those events."
4PR = "r1"
Brad Bishopf1cc41b2017-05-31 14:08:33 -04005HOMEPAGE = "http://github.com/openbmc/phosphor-dbus-monitor"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
8SRC_URI = "git://github.com/openbmc/phosphor-dbus-monitor"
Andrew Geissler07e715b2018-10-18 19:50:19 +00009SRCREV = "0b45a3ce6d21e70453ed3d4a7dfcc2bef0865e7f"
Brad Bishopf1cc41b2017-05-31 14:08:33 -040010
11inherit autotools \
12 pkgconfig \
13 pythonnative \
14 phosphor-dbus-monitor \
15 obmc-phosphor-systemd
16
Brad Bishopeafda3b2017-08-02 01:32:43 -040017PACKAGE_BEFORE_PN = "phosphor-msl-verify"
18SYSTEMD_PACKAGES = "${PN} phosphor-msl-verify"
19SYSTEMD_SERVICE_phosphor-msl-verify = "phosphor-msl-verify.service"
20
Brad Bishopf1cc41b2017-05-31 14:08:33 -040021DEPENDS += " \
22 ${PN}-config-native \
23 phosphor-logging \
24 autoconf-archive-native \
Brad Bishopf06d3b62018-01-26 21:48:20 -050025 sdbusplus-native \
Brad Bishopf1cc41b2017-05-31 14:08:33 -040026 gtest \
Andrew Geissler76158002018-09-05 00:30:15 +000027 phosphor-snmp \
Brad Bishopf1cc41b2017-05-31 14:08:33 -040028 "
29RDEPENDS_${PN} += " \
30 sdbusplus \
31 phosphor-dbus-interfaces \
32 phosphor-logging \
Andrew Geissler76158002018-09-05 00:30:15 +000033 phosphor-snmp \
Brad Bishopf1cc41b2017-05-31 14:08:33 -040034 "
35
Brad Bishopeafda3b2017-08-02 01:32:43 -040036RDEPENDS_phosphor-msl-verify += " \
37 sdbusplus \
38 phosphor-dbus-interfaces \
39 phosphor-logging \
Andrew Geissler76158002018-09-05 00:30:15 +000040 phosphor-snmp \
Brad Bishopeafda3b2017-08-02 01:32:43 -040041 "
42FILES_phosphor-msl-verify = "${sbindir}/phosphor-msl-verify"
43
Brad Bishopf1cc41b2017-05-31 14:08:33 -040044S = "${WORKDIR}/git"
45
46EXTRA_OECONF = " \
47 YAML_PATH=${STAGING_DIR_NATIVE}${config_dir} \
48 "